summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/lua/lua-arch.patch
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-23 01:07:07 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-23 01:07:07 (GMT)
commitf0598b8dbd94636f2040b829d90ec48484331aa6 (patch)
treeff90f3f35706b034214261cf2ceeeff0458a7528 /abs/extra/community/lua/lua-arch.patch
parent2ead123b69209a430ff3e6483b9f9f42194fd4ae (diff)
downloadlinhes_pkgbuild-f0598b8dbd94636f2040b829d90ec48484331aa6.zip
linhes_pkgbuild-f0598b8dbd94636f2040b829d90ec48484331aa6.tar.gz
linhes_pkgbuild-f0598b8dbd94636f2040b829d90ec48484331aa6.tar.bz2
lua: recompile
Diffstat (limited to 'abs/extra/community/lua/lua-arch.patch')
-rw-r--r--abs/extra/community/lua/lua-arch.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/abs/extra/community/lua/lua-arch.patch b/abs/extra/community/lua/lua-arch.patch
index 7d6d331..cc1f3ce 100644
--- a/abs/extra/community/lua/lua-arch.patch
+++ b/abs/extra/community/lua/lua-arch.patch
@@ -35,7 +35,7 @@ diff -ur lua-5.1.orig/src/Makefile lua-5.1/src/Makefile
$(RANLIB) $@
+$(LUA_SO): $(CORE_O) $(LIB_O)
-+ $(CC) -shared -ldl -Wl,-soname,liblua.so -o $@.5.1 $? $(MYLDFLAGS)
++ $(CC) -shared -ldl -Wl,-soname,liblua.so -o $@.5.1 $? -lm $(MYLDFLAGS)
+ ln -s $@.5.1 $@
+
$(LUA_T): $(LUA_O) $(LUA_A)