summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/mythpywii/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
commitb172f79fadb565ecfbcec9508f9377d8618a4f4c (patch)
treebf8823b07e3313c3afa000a9b31e4f9a735cb818 /abs/extra/community/mythpywii/PKGBUILD
parentf9d54ab7c3853208484e304bc6cf40ab0f79d400 (diff)
parent5e7027c6194237ca1dc5fcbb3648483a970fb500 (diff)
downloadlinhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.zip
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.gz
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra/community/mythpywii/PKGBUILD')
-rw-r--r--abs/extra/community/mythpywii/PKGBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/abs/extra/community/mythpywii/PKGBUILD b/abs/extra/community/mythpywii/PKGBUILD
index 4b57c77..38e456f 100644
--- a/abs/extra/community/mythpywii/PKGBUILD
+++ b/abs/extra/community/mythpywii/PKGBUILD
@@ -2,17 +2,27 @@
# Maintainer: Cecil Watson<knoppmyth@gmail.com>
pkgname=mythpywii
-pkgver=1
-pkgrel=1
+pkgver=17
+pkgrel=8
pkgdesc="Control MythTV using Wiimote."
arch=('i686' 'x86_64')
license=('GPL2')
url="http://www.benjiegillam.com/"
depends=('bluez' 'python-pybluez' 'cwiid-svn')
-#install=mythpywii.install
-source=(http://www.benjiegillam.com/code/myth_py_wii.py)
+install=mythpywii.install
+source=(http://www.benjiegillam.com/code/myth_py_wii.py \
+ wiimote.rules mythpywii.install CONTROLS)
build() {
- mkdir -p $startdir/pkg/usr/bin
- install -D -m 755 myth_py_wii.py $startdir/pkg/usr/bin
+ install -D -m755 ${srcdir}/myth_py_wii.py ${startdir}/pkg/usr/bin/myth_py_wii.py || return 1
+ install -D -m644 ${srcdir}/wiimote.rules ${startdir}/pkg/etc/udev/rules.d/z90-wiimote.rules || return 1
+ install -d -o mythtv -g mythtv ${startdir}/pkg/home/mythtv/.cwiid/wminput || return 1
+ install -D -m755 -o mythtv -g mythtv /etc/cwiid/wminput/{acc_led,buttons,gamepad,neverball,nunchuk_stick2btn,acc_ptr,ir_ptr,nunchuk_acc_ptr} ${startdir}/pkg/home/mythtv/.cwiid/wminput || return 1
+ install -D -m644 ${srcdir}/CONTROLS ${startdir}/pkg/usr/share/docs/mythpywii/CONTROLS || return 1
+ cd ${startdir}/pkg/home/mythtv/.cwiid/wminput
+ ln -s acc_led default
}
+md5sums=('5bd5e1bb9c4cbfabbffdb28ff616e83b'
+ '0d817a971d414b9320587a4cf289386b'
+ '64fa8dbd324dac68f71753ebd828d358'
+ '0872cbdb3def3dd9aa2b97b191ad76d8')