summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/squeezeboxserver/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
commitb172f79fadb565ecfbcec9508f9377d8618a4f4c (patch)
treebf8823b07e3313c3afa000a9b31e4f9a735cb818 /abs/extra/community/squeezeboxserver/PKGBUILD
parentf9d54ab7c3853208484e304bc6cf40ab0f79d400 (diff)
parent5e7027c6194237ca1dc5fcbb3648483a970fb500 (diff)
downloadlinhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.zip
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.gz
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra/community/squeezeboxserver/PKGBUILD')
-rw-r--r--abs/extra/community/squeezeboxserver/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/extra/community/squeezeboxserver/PKGBUILD b/abs/extra/community/squeezeboxserver/PKGBUILD
new file mode 100644
index 0000000..45db11f
--- /dev/null
+++ b/abs/extra/community/squeezeboxserver/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Anton Prins <uar at prinsonline dot demon dot nl>
+
+pkgname=squeezeboxserver
+pkgver=7.4.1
+pkgrel=1
+pkgdesc="Powerful streaming audio server from Slim Devices"
+depends=(
+# unknown to me, default arch install + openssh handles it
+ )
+
+source=(http://downloads.slimdevices.com/SqueezeboxServer_v${pkgver}/squeezeboxserver-${pkgver}.tgz
+ $pkgname.rc
+ $pkgname.conf.d
+ )
+
+url="http://www.slimdevices.com/pi_features.html"
+license=('GPL')
+arch=('i686' 'x86_64')
+install=squeezeboxserver.install
+
+#not sure how to handle the build number -28947?
+build() {
+cd $startdir/src/squeezeboxserver-${pkgver}-28947 || return 1
+
+mkdir -p $startdir/pkg/home/squeezeboxserver || return 1
+cp -a * $startdir/pkg/home/squeezeboxserver || return 1
+install -D -m755 ../squeezeboxserver.rc $startdir/pkg/etc/rc.d/squeezeboxserver || return 1
+install -D -m644 ../squeezeboxserver.conf.d $startdir/pkg/etc/conf.d/squeezeboxserver || return 1
+mkdir $startdir/pkg/home/squeezeboxserver/prefs
+}
+
+md5sums=('fa65636e7df75ae7af884a2efa184639'
+ '5e57982c257797badbf72c2ae04994f7'
+ 'aa65896541958e119e63ee7c96be39af')