summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/twisted/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <jams@linhes.org>2010-12-04 23:48:49 (GMT)
committerJames Meyer <jams@linhes.org>2010-12-04 23:48:49 (GMT)
commit037ab1a6a2fee07c83b47dc4d4ffd629b9052e85 (patch)
treea4256da38a768da362aad34ad9a8bcc7da611c30 /abs/extra/community/twisted/PKGBUILD
parent0b251e4b5f6d56e5aba84aaf780fbf4e6a289245 (diff)
parent2ddfcdc1360af607e5925afe0e0f3562ad538738 (diff)
downloadlinhes_pkgbuild-037ab1a6a2fee07c83b47dc4d4ffd629b9052e85.zip
linhes_pkgbuild-037ab1a6a2fee07c83b47dc4d4ffd629b9052e85.tar.gz
linhes_pkgbuild-037ab1a6a2fee07c83b47dc4d4ffd629b9052e85.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/community/twisted/PKGBUILD')
-rw-r--r--abs/extra/community/twisted/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/extra/community/twisted/PKGBUILD b/abs/extra/community/twisted/PKGBUILD
new file mode 100644
index 0000000..e008e92
--- /dev/null
+++ b/abs/extra/community/twisted/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 94591 2010-10-08 12:55:33Z ibiru $
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+
+pkgname=twisted
+pkgver=10.1.0
+pkgrel=1
+pkgdesc="Asynchronous networking framework written in Python."
+arch=('i686' 'x86_64')
+url="http://twistedmatrix.com/"
+license=('MIT')
+depends=('python2' 'pycrypto' 'zope-interface')
+optdepends=('pyopenssl'
+ 'python-soappy:for twisted.web.soap')
+install=twisted.install
+source=(http://tmrc.mit.edu/mirror/twisted/Twisted/${pkgver%.*}/Twisted-${pkgver}.tar.bz2)
+md5sums=('04cca97506e830074cffc1965297da3f')
+build() {
+ cd "${srcdir}/Twisted-${pkgver}"
+
+ python2 setup.py install --prefix=/usr --root=$pkgdir --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+
+ sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
+ -i ${pkgdir}/usr/lib/python2.7/site-packages/twisted/trial/test/scripttest.py
+ sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
+ -i ${pkgdir}/usr/lib/python2.7/site-packages/twisted/mail/test/pop3testserver.py
+}