summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/zvbi/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2011-08-06 05:21:27 (GMT)
committerJames Meyer <james.meyer@operamail.com>2011-08-06 05:21:27 (GMT)
commit7a18aa65cbe27c5213df0f2642e381bc0a2d5e03 (patch)
tree6b8206f2ee5f9bdd0950c276bbad5685c203dbb4 /abs/extra/community/zvbi/PKGBUILD
parentfd8ebb392cd04e7c59ae0dd696d93f0ef509b89c (diff)
parent5b37c394102e30e4751fd925dae8c299bc4432df (diff)
downloadlinhes_pkgbuild-7a18aa65cbe27c5213df0f2642e381bc0a2d5e03.zip
linhes_pkgbuild-7a18aa65cbe27c5213df0f2642e381bc0a2d5e03.tar.gz
linhes_pkgbuild-7a18aa65cbe27c5213df0f2642e381bc0a2d5e03.tar.bz2
Merge branch 'testing' of ssh://jams@linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/community/zvbi/PKGBUILD')
-rw-r--r--abs/extra/community/zvbi/PKGBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/abs/extra/community/zvbi/PKGBUILD b/abs/extra/community/zvbi/PKGBUILD
index f638f29..9bc150c 100644
--- a/abs/extra/community/zvbi/PKGBUILD
+++ b/abs/extra/community/zvbi/PKGBUILD
@@ -1,21 +1,25 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Alexander Baldeck <alexander@archlinux.org>
+# $Id$
+# Maintainer:
+# Contributor: Alexander Baldeck <alexander@archlinux.org>
# Contributor: dorphell <dorphell@archlinux.org>
pkgname=zvbi
-pkgver=0.2.26
-pkgrel=1
-pkgdesc="zvbi is needed for zapping"
+pkgver=0.2.33
+pkgrel=3
+pkgdesc="VBI capture and decoding library"
+url="http://zapping.sourceforge.net/cgi-bin/view/ZVBI/WebHome"
arch=(i686 x86_64)
-depends=('libpng')
+depends=('libpng' 'libx11')
license=('GPL')
options=('!libtool')
-source=(http://downloads.sourceforge.net/sourceforge/zapping/$pkgname-$pkgver.tar.bz2)
-url="http://zapping.sourceforge.net/cgi-bin/view/ZVBI/WebHome"
+source=(http://downloads.sourceforge.net/sourceforge/zapping/${pkgname}-${pkgver}.tar.bz2
+ fix-includes.patch)
+md5sums=('1741a6045c3eedfb611d645f2da69ac8'
+ '38766bc59e1571133d0399f0102da653')
build() {
- cd $startdir/src/$pkgname-$pkgver
- ./configure --prefix=/usr
- make || return 1
- make prefix=$startdir/pkg/usr install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/fix-includes.patch"
+ ./configure --prefix=/usr --disable-static --mandir=/usr/share/man
+ make
+ make DESTDIR="${pkgdir}" install
}
-md5sums=('82805319ca61f6ffd7b7bb64d7433448')