summaryrefslogtreecommitdiffstats
path: root/abs/extra/crystalhd-git/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-06 17:34:48 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-06 17:34:48 (GMT)
commita88e0a4caaee4269707417416f8e36c754ea6e16 (patch)
treede63f290d0c85422f5c9bb8bfb3e186030f79080 /abs/extra/crystalhd-git/PKGBUILD
parent9b21e2c89af805f7e2e3014075318587ae479396 (diff)
parent28df92c527607da6a77cbc2ba0f8f62bc6dff548 (diff)
downloadlinhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.zip
linhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.tar.gz
linhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/crystalhd-git/PKGBUILD')
-rw-r--r--abs/extra/crystalhd-git/PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/abs/extra/crystalhd-git/PKGBUILD b/abs/extra/crystalhd-git/PKGBUILD
new file mode 100644
index 0000000..538c0ae
--- /dev/null
+++ b/abs/extra/crystalhd-git/PKGBUILD
@@ -0,0 +1,44 @@
+# Contributor: Petteri Tolonen <petteri.tolonen[at]gmail.com>
+# Maintainer: Petteri Tolonen <petteri.tolonen[at]gmail.com>
+
+pkgname=crystalhd-git
+pkgver=`date +%Y%m%d`
+pkgrel=1
+pkgdesc="Broadcom Crystal HD kernel module from git.wilsonet.com"
+arch=('i686' 'x86_64')
+url="http://git.wilsonet.com/crystalhd.git/"
+license=('GPL2')
+depends=()
+makedepends=('autoconf' 'kernel26-headers>=2.6.32.9' 'make' 'git')
+conflicts=('crystalhd')
+install='crystalhd-git.install'
+_gitroot='git://git.wilsonet.com/crystalhd.git'
+_gitname='crystalhd'
+
+build() {
+
+ cd $startdir/src
+
+ msg "Connecting to git.wilsonet.com GIT server...."
+
+ if [ -d $startdir/src/$_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ cd $_gitname
+ fi
+
+ cd driver/linux
+
+ autoconf
+ ./configure --prefix=/usr
+ make KDIR=/lib/modules/2.6.34-LinHES/build || return 1
+ mkdir -p $pkgdir/etc/udev/rules.d
+ mkdir -p $pkgdir/lib/modules/$(uname -r)/kernel/drivers/video/broadcom
+
+ cp -f 20-crystalhd.rules $pkgdir/etc/udev/rules.d/
+ install -d $pkgdir/lib/modules/$(uname -r)/kernel/drivers/video/broadcom
+ install -m 0644 crystalhd.ko $pkgdir/lib/modules/$(uname -r)/kernel/drivers/video/broadcom
+
+}