summaryrefslogtreecommitdiffstats
path: root/abs/extra/dcraw
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-06 17:34:48 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-06 17:34:48 (GMT)
commita88e0a4caaee4269707417416f8e36c754ea6e16 (patch)
treede63f290d0c85422f5c9bb8bfb3e186030f79080 /abs/extra/dcraw
parent9b21e2c89af805f7e2e3014075318587ae479396 (diff)
parent28df92c527607da6a77cbc2ba0f8f62bc6dff548 (diff)
downloadlinhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.zip
linhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.tar.gz
linhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/dcraw')
-rw-r--r--abs/extra/dcraw/PKGBUILD41
-rw-r--r--abs/extra/dcraw/dcraw.install17
-rw-r--r--abs/extra/dcraw/license.txt16
3 files changed, 74 insertions, 0 deletions
diff --git a/abs/extra/dcraw/PKGBUILD b/abs/extra/dcraw/PKGBUILD
new file mode 100644
index 0000000..8468c92
--- /dev/null
+++ b/abs/extra/dcraw/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id: PKGBUILD 84664 2010-07-03 05:41:46Z allan $
+# Maintainer: tobias <tobias@archlinux.org>
+# Contributor: Tobias Kieslich <tobias@justdreams.de>
+
+# Note for rebuilders:
+# dcraw.c is released as pure C file, not as a package with a changing version
+# number in the name. The name of the file to be downloaded is always the same!
+# So if you are a bad boy (Santa knows everything!) and build as root, this file
+# will be saved in /var/cache/pacman/src . Therefore, rebuilding a later version
+# likely will fail due to an MD5 error. If so, delete the files from the cache
+# to force a new download.
+
+pkgname=dcraw
+pkgver=1.438
+pkgrel=1
+pkgdesc="A command line based converter for digicams raw output"
+arch=('i686' 'x86_64')
+url="http://www.cybercom.net/~dcoffin/dcraw/"
+license=('custom')
+depends=('lcms')
+source=(http://www.cybercom.net/~dcoffin/${pkgname}/${pkgname}.c
+ http://www.cybercom.net/~dcoffin/${pkgname}/${pkgname}.1
+ license.txt)
+
+build() {
+ cd "${srcdir}"
+ gcc -o dcraw ${CFLAGS} dcraw.c -lm -ljpeg -llcms
+}
+
+package() {
+ cd "${srcdir}"
+ install -Dm755 ${pkgname} "${pkgdir}"/usr/bin/${pkgname}
+
+ # install a manpage, provided separately on authors homepage
+ install -Dm644 ${pkgname}.1 "${pkgdir}"/usr/share/man/man1/${pkgname}.1
+
+ install -Dm644 license.txt "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt
+}
+md5sums=('108f0c14a5be4d092c7ffa8460044fb3'
+ '6ba2a797c4ad698589f83171d6b36396'
+ '110b4604a6dacd5537339c4082e9e12a')
diff --git a/abs/extra/dcraw/dcraw.install b/abs/extra/dcraw/dcraw.install
new file mode 100644
index 0000000..0b3d1bf
--- /dev/null
+++ b/abs/extra/dcraw/dcraw.install
@@ -0,0 +1,17 @@
+post_install() {
+ cat << EOF
+
+NOTE for drcaw:
+----
+ ==> dcraw provides the simple commandline tools for raw conversion. If you
+ ==> are looking for a more sophisticated way consider gimp-ufraw, which
+ ==> provides a gimp-plugin and a standalone application that can even convert
+ ==> to 16-bit tiff files (which you can use in cinepaint eg.) So please do a
+ ==> 'pacman -S gimp-ufraw' to get it.
+
+EOF
+}
+
+post_upgrade() {
+ post_install $1
+}
diff --git a/abs/extra/dcraw/license.txt b/abs/extra/dcraw/license.txt
new file mode 100644
index 0000000..5803cf6
--- /dev/null
+++ b/abs/extra/dcraw/license.txt
@@ -0,0 +1,16 @@
+This is a command-line ANSI C program to convert raw photos from
+any digital camera on any computer running any operating system.
+
+No license is required to download and use dcraw.c. However,
+to lawfully redistribute this code, you must either (a) include
+full source code* for all executable files containing RESTRICTED
+functions, (b) remove all RESTRICTED functions, re-implement them,
+or copy them from an earlier, unrestricted Revision of dcraw.c,
+or (c) purchase a license from the author.
+
+The functions that process Foveon images have been RESTRICTED
+since Revision 1.237. All other code remains free for all uses.
+
+*If you have not modified dcraw.c in any way, a link to my
+homepage qualifies as "full source code".
+