summaryrefslogtreecommitdiffstats
path: root/abs/extra/dnsmasq/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
commitb172f79fadb565ecfbcec9508f9377d8618a4f4c (patch)
treebf8823b07e3313c3afa000a9b31e4f9a735cb818 /abs/extra/dnsmasq/PKGBUILD
parentf9d54ab7c3853208484e304bc6cf40ab0f79d400 (diff)
parent5e7027c6194237ca1dc5fcbb3648483a970fb500 (diff)
downloadlinhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.zip
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.gz
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra/dnsmasq/PKGBUILD')
-rw-r--r--abs/extra/dnsmasq/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/abs/extra/dnsmasq/PKGBUILD b/abs/extra/dnsmasq/PKGBUILD
new file mode 100644
index 0000000..f888ccd
--- /dev/null
+++ b/abs/extra/dnsmasq/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id: PKGBUILD 66607 2010-02-01 01:42:17Z giovanni $
+# Maintainer: Paul Mattal <paul@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=dnsmasq
+pkgver=2.55
+pkgrel=1
+pkgdesc="Lightweight, easy to configure DNS forwarder and DHCP server"
+url="http://www.thekelleys.org.uk/dnsmasq/doc.html"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('glibc' 'bash')
+makedepends=('libcap>=2.16')
+backup=('etc/dnsmasq.conf')
+install=
+source=("http://www.thekelleys.org.uk/$pkgname/$pkgname-$pkgver.tar.gz"
+ 'rc.dnsmasq')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ # Build
+ make || return 1
+
+ # Install
+ install -d $pkgdir/etc/rc.d || return 1
+ make PREFIX=/usr DESTDIR=$pkgdir install || return 1
+
+ install -D -m755 \
+ $srcdir/rc.dnsmasq $pkgdir/etc/rc.d/dnsmasq || return 1
+ install -D -m644 \
+ dnsmasq.conf.example $pkgdir/etc/dnsmasq.conf || return 1
+
+ # Make the Required Directories for DHCP Server Default Directories
+ install -d $pkgdir/var/db || return 1
+ install -d $pkgdir/var/lib/misc || return 1
+}
+
+# vim: ts=2 sw=2 et ft=sh
+md5sums=('b093d7c6bc7f97ae6fd35d048529232a'
+ 'e956eee1ec24212a3254d2b168187495')