summaryrefslogtreecommitdiffstats
path: root/abs/extra/doxygen/PKGBUILD.orig
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
commitb172f79fadb565ecfbcec9508f9377d8618a4f4c (patch)
treebf8823b07e3313c3afa000a9b31e4f9a735cb818 /abs/extra/doxygen/PKGBUILD.orig
parentf9d54ab7c3853208484e304bc6cf40ab0f79d400 (diff)
parent5e7027c6194237ca1dc5fcbb3648483a970fb500 (diff)
downloadlinhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.zip
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.gz
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra/doxygen/PKGBUILD.orig')
-rw-r--r--abs/extra/doxygen/PKGBUILD.orig24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/extra/doxygen/PKGBUILD.orig b/abs/extra/doxygen/PKGBUILD.orig
new file mode 100644
index 0000000..f4b09d2
--- /dev/null
+++ b/abs/extra/doxygen/PKGBUILD.orig
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 14308 2008-10-05 15:59:28Z dan $
+# Maintainer: Dan McGee <dan@archlinux.org>
+pkgname=doxygen
+pkgver=1.7.1
+pkgrel=1
+pkgdesc="A documentation system for C++, C, Java, IDL and PHP"
+license=('GPL')
+arch=(i686 x86_64)
+url="http://www.doxygen.org/"
+depends=('gcc-libs')
+# qt required to build and run doxywizard, but don't want to drag it in
+makedepends=('flex' 'qt3')
+optdepends=('graphviz: for caller/callee graph generation'
+ 'qt3: for doxywizard')
+source=(ftp://ftp.stack.nl/pub/users/dimitri/${pkgname}-${pkgver}.src.tar.gz)
+
+build() {
+ . /etc/profile.d/qt3.sh
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix /usr --with-doxywizard
+ make || return 1
+ make INSTALL=${startdir}/pkg/usr MAN1DIR=share/man/man1 install
+}
+md5sums=('13e76e10fb55581a16ee04de35c264f0')