summaryrefslogtreecommitdiffstats
path: root/abs/extra/efibootmgr/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:46:02 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:46:02 (GMT)
commit6bdab42c6f586f3ff18992cfa563877b9cfa45ef (patch)
treeac9923586da3137ac1f3984bcd820c8199f7d2be /abs/extra/efibootmgr/PKGBUILD
parentb4e97449825d539b0d15a6fd56ed40abe73b1207 (diff)
downloadlinhes_pkgbuild-6bdab42c6f586f3ff18992cfa563877b9cfa45ef.zip
linhes_pkgbuild-6bdab42c6f586f3ff18992cfa563877b9cfa45ef.tar.gz
linhes_pkgbuild-6bdab42c6f586f3ff18992cfa563877b9cfa45ef.tar.bz2
efibootmgr .5.4
-new
Diffstat (limited to 'abs/extra/efibootmgr/PKGBUILD')
-rwxr-xr-xabs/extra/efibootmgr/PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/abs/extra/efibootmgr/PKGBUILD b/abs/extra/efibootmgr/PKGBUILD
new file mode 100755
index 0000000..0fd7bb2
--- /dev/null
+++ b/abs/extra/efibootmgr/PKGBUILD
@@ -0,0 +1,52 @@
+# $Id: PKGBUILD 156423 2012-04-18 07:53:47Z tpowa $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor : Murtuza Akhtari <inxsible at gmail dot com>
+# Contributor: Keshav P R <skodabenz at rocketmail dot com>
+
+pkgname=efibootmgr
+pkgver=0.5.4
+pkgrel=3
+pkgdesc="Tool to modify UEFI Firmware Boot Manager Variables."
+arch=('i686' 'x86_64')
+url="http://linux.dell.com/efibootmgr/"
+license=('GPL2')
+depends=('zlib' 'pciutils')
+makedepends=()
+provides=()
+options=(strip purge docs zipman !emptydirs)
+
+source=("http://linux.dell.com/efibootmgr/permalink/${pkgname}-${pkgver}.tar.gz"
+ 'efibootmgr_after_0.5.4_git.patch'
+ 'efibootmgr_default_to_grub2.patch')
+
+build () {
+ rm -rf ${srcdir}/efibootmgr-${pkgver}_build/ || true
+
+ cp -r ${srcdir}/efibootmgr-${pkgver} ${srcdir}/efibootmgr-${pkgver}_build
+
+ cd ${srcdir}/efibootmgr-${pkgver}_build/
+
+ patch -Np1 -i ${srcdir}/efibootmgr_after_0.5.4_git.patch
+ patch -Np1 -i ${srcdir}/efibootmgr_default_to_grub2.patch
+ echo
+
+ CFLAGS= make
+ echo
+
+}
+
+
+package() {
+
+ mkdir -p ${pkgdir}/usr/sbin/
+ mkdir -p ${pkgdir}/usr/share/man/man8/
+
+ cd ${srcdir}/efibootmgr-${pkgver}_build/
+
+ install -D -m755 ${srcdir}/efibootmgr-${pkgver}_build/src/efibootmgr/efibootmgr ${pkgdir}/usr/sbin/efibootmgr
+ install -D -m644 ${srcdir}/efibootmgr-${pkgver}_build/src/man/man8/efibootmgr.8 ${pkgdir}/usr/share/man/man8/efibootmgr.8
+
+}
+md5sums=('cfcf24752d6461b73f7ba964bbf73169'
+ '29730052de0d6911457a26011f8ddb6e'
+ 'b99b8f79842b96c241a0b0fcfb75c778')