summaryrefslogtreecommitdiffstats
path: root/abs/extra/fakeroot
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/extra/fakeroot
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/extra/fakeroot')
-rw-r--r--abs/extra/fakeroot/PKGBUILD28
-rw-r--r--abs/extra/fakeroot/fakeroot.install30
2 files changed, 58 insertions, 0 deletions
diff --git a/abs/extra/fakeroot/PKGBUILD b/abs/extra/fakeroot/PKGBUILD
new file mode 100644
index 0000000..f8dd4b2
--- /dev/null
+++ b/abs/extra/fakeroot/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 29508 2009-03-09 17:06:43Z andyrtr $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Jochem Kossen <j.kossen@home.nl>
+
+pkgname=fakeroot
+pkgver=1.12.2
+pkgrel=2
+pkgdesc="Gives a fake root environment, useful for building packages as a non-privileged user"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://packages.debian.org/fakeroot"
+groups=('base-devel')
+install=fakeroot.install
+depends=('glibc' 'filesystem' 'grep' 'sed')
+options=('!libtool')
+source=(http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.tar.gz)
+md5sums=('1eb7d972a19159035892e7d132602726')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+ ./configure --prefix=/usr --libdir=/usr/lib/libfakeroot \
+ --disable-static --with-ipc=sysv
+ # --with-ipc=tcp is currently broken and no option on smp systems
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+ # install README for sysv/tcp usage
+ install -Dm644 $srcdir/$pkgname-$pkgver/README $pkgdir/usr/share/doc/$pkgname/README
+}
diff --git a/abs/extra/fakeroot/fakeroot.install b/abs/extra/fakeroot/fakeroot.install
new file mode 100644
index 0000000..c2f62a7
--- /dev/null
+++ b/abs/extra/fakeroot/fakeroot.install
@@ -0,0 +1,30 @@
+# arg 1: the new package version
+post_install() {
+ if [ ! "`grep /usr/lib/libfakeroot etc/ld.so.conf`" ]; then
+ echo -n "updating /etc/ld.so.conf... "
+ echo "/usr/lib/libfakeroot" >>etc/ld.so.conf
+ sbin/ldconfig -r .
+ echo "done."
+ fi
+echo "The package is built using sysv ipc. If this causes segfaults"
+echo "see included README file and rebuild the pkg --with-ipc=tcp"
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+# arg 1: the old package version
+pre_remove() {
+ echo -ne "\nupdating /etc/ld.so.conf... "
+ sed -i -e '/\/usr\/lib\/libfakeroot/d' etc/ld.so.conf
+ sbin/ldconfig -r .
+ echo "done."
+}
+
+op=$1
+shift
+
+$op $*