summaryrefslogtreecommitdiffstats
path: root/abs/extra/fontforge/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <mihanson@linhes.org>2012-04-14 05:13:05 (GMT)
committerMichael Hanson <mihanson@linhes.org>2012-04-14 05:13:05 (GMT)
commit5e96cb93d1f17a98a8f8a118b2659ea4d71d3f43 (patch)
treeacde2ddc972337f648a826f3d961dcb8bebf892a /abs/extra/fontforge/PKGBUILD
parent8e721470713e6a5a164f1d7682b0d248cb87b03c (diff)
parent502a19b42d9df3fb3c3e521a37eebd20f9fbd984 (diff)
downloadlinhes_pkgbuild-5e96cb93d1f17a98a8f8a118b2659ea4d71d3f43.zip
linhes_pkgbuild-5e96cb93d1f17a98a8f8a118b2659ea4d71d3f43.tar.gz
linhes_pkgbuild-5e96cb93d1f17a98a8f8a118b2659ea4d71d3f43.tar.bz2
Merge branch 'testing' of linhes.org:linhes_pkgbuild into testing
Conflicts: abs/extra/bluez/PKGBUILD abs/extra/bluez/__changelog
Diffstat (limited to 'abs/extra/fontforge/PKGBUILD')
-rw-r--r--abs/extra/fontforge/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/abs/extra/fontforge/PKGBUILD b/abs/extra/fontforge/PKGBUILD
new file mode 100644
index 0000000..ff53b21
--- /dev/null
+++ b/abs/extra/fontforge/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id$
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Eric Belanger <eric@archlinux.org>
+# Contributor: William Rea <sillywilly@gmail.com>
+
+pkgname=fontforge
+pkgver=20120119
+pkgrel=1
+pkgdesc='Outline and bitmap font editor'
+arch=('i686' 'x86_64')
+url='http://fontforge.sourceforge.net/'
+license=('BSD')
+depends=('libxkbui' 'libxi' 'libxml2' 'pango' 'giflib' 'libtiff' 'python2' 'libspiro')
+options=('!libtool' '!makeflags')
+source=("ftp://ftp.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.xz")
+sha1sums=('2c363af075e77bf35d21ee1939e3d6ab39a9f80c')
+
+# git clone git://fontforge.git.sourceforge.net/gitroot/fontforge/fontforge; cd fontforge; git archive --prefix=${pkgname}-${pkgver}/ master | xz > ../${pkgname}-${pkgver}.tar.xz
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -i 's/python /python2 /g' Makefile.dynamic.in
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-type3 \
+ --enable-devicetables \
+ --enable-double \
+ --with-regular-link \
+ --with-python=python2 \
+ --enable-pyextension \
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}