summaryrefslogtreecommitdiffstats
path: root/abs/extra/gconf
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:46:59 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:46:59 (GMT)
commit8994e4b247c0c4715827c646b1ce932ef1a13f63 (patch)
tree8ebcdf4d5c2d80e84d6cf66cc3fe9cb902d7cbb1 /abs/extra/gconf
parent536845a63eb4bd7391b941b838b726114e64fc72 (diff)
downloadlinhes_pkgbuild-8994e4b247c0c4715827c646b1ce932ef1a13f63.zip
linhes_pkgbuild-8994e4b247c0c4715827c646b1ce932ef1a13f63.tar.gz
linhes_pkgbuild-8994e4b247c0c4715827c646b1ce932ef1a13f63.tar.bz2
gconf 3.2.5
-new
Diffstat (limited to 'abs/extra/gconf')
-rw-r--r--abs/extra/gconf/PKGBUILD42
1 files changed, 24 insertions, 18 deletions
diff --git a/abs/extra/gconf/PKGBUILD b/abs/extra/gconf/PKGBUILD
index 66de23f..9a4d1f6 100644
--- a/abs/extra/gconf/PKGBUILD
+++ b/abs/extra/gconf/PKGBUILD
@@ -1,45 +1,51 @@
-# $Id: PKGBUILD 91729 2010-09-27 18:54:15Z ibiru $
+# $Id: PKGBUILD 156770 2012-04-23 09:05:12Z ibiru $
# Maintainer: Jan de Groot <jan@archlinux.org>
pkgname=gconf
-pkgver=2.32.0
-pkgrel=1
+pkgver=3.2.5
+pkgrel=2
pkgdesc="A configuration database system"
-arch=('i686' 'x86_64')
+arch=(i686 x86_64)
license=('LGPL')
-depends=('orbit2>=2.14.18' 'gtk2>=2.22.0' 'libxml2>=2.7.7' 'polkit>=0.96' 'libldap>=2.4.22' 'dbus-glib>=0.86')
-makedepends=('pkgconfig' 'intltool' 'gtk-doc' 'gobject-introspection')
+depends=('libxml2' 'polkit' 'libldap' 'dbus-glib' 'gtk3')
+makedepends=('intltool' 'gtk-doc' 'gobject-introspection')
options=('!libtool')
install=gconf.install
url="http://www.gnome.org"
-source=(http://ftp.gnome.org/pub/gnome/sources/GConf/2.32/GConf-${pkgver}.tar.bz2
+source=(http://ftp.gnome.org/pub/gnome/sources/GConf/3.2/GConf-$pkgver.tar.xz
gconf-merge-schema
gconfpkg
gconf-reload.patch
01_xml-gettext-domain.patch)
-sha256sums=('54dd1dd7f49928a9cc42574bef6ef0481753770fc19986dc2004bbb7fac977a0'
+sha256sums=('4ddea9503a212ee126c5b46a0a958fd5484574c3cb6ef2baf38db02e819e58c6'
'ee6b6e6f4975dad13a8c45f1c1f0547a99373bdecdcd6604bfc12965c328a028'
'bf1928718caa5df2b9e54a13cfd0f15a8fe0e09e86b84385ce023616a114e898'
'567b78d8b4b4bbcb77c5f134d57bc503c34867fcc6341c0b01716bcaa4a21694'
'c883dec2b96978874a53700cfe7f26f24f8296767203e970bc6402b4b9945eb8')
build() {
- cd "${srcdir}/GConf-${pkgver}"
+ cd "GConf-$pkgver"
# Patch from fedora - reloads gconf after installing schemas
- patch -Np1 -i "${srcdir}/gconf-reload.patch"
+ patch -Np1 -i "$srcdir/gconf-reload.patch"
# http://bugzilla.gnome.org/show_bug.cgi?id=568845
- patch -Np1 -i "${srcdir}/01_xml-gettext-domain.patch"
+ patch -Np1 -i "$srcdir/01_xml-gettext-domain.patch"
+
+ # Python2 fix
+ sed -i '1s|#!/usr/bin/env python$|&2|' gsettings/gsettings-schema-convert
./configure --prefix=/usr --sysconfdir=/etc \
--localstatedir=/var --libexecdir=/usr/lib/GConf \
- --disable-static --enable-defaults-service
+ --disable-static --enable-defaults-service --with-gtk=3.0 \
+ --disable-orbit
+
make pkglibdir=/usr/lib/GConf
}
+
package() {
- cd "${srcdir}/GConf-${pkgver}"
- make DESTDIR="${pkgdir}" install
- install -m755 -d "${pkgdir}/etc/gconf/gconf.xml.system"
- install -m755 "${srcdir}/gconf-merge-schema" "${pkgdir}/usr/bin/"
- install -d -m755 "${pkgdir}/usr/sbin"
- install -m755 "${srcdir}/gconfpkg" "${pkgdir}/usr/sbin/"
+ cd "GConf-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ install -m755 -d "$pkgdir/etc/gconf/gconf.xml.system"
+ install -m755 "$srcdir/gconf-merge-schema" "$pkgdir/usr/bin/"
+ install -Dm755 "$srcdir/gconfpkg" "$pkgdir/usr/sbin/gconfpkg"
}