summaryrefslogtreecommitdiffstats
path: root/abs/extra/gnome-desktop
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-01 03:36:38 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-01 03:36:38 (GMT)
commit2394bb03037c7980d15c21a3224f3ea5874fa2ae (patch)
tree5032abec1b9b87a4bb078175ed5fd2064c183c59 /abs/extra/gnome-desktop
parentb97bc609acdcce08d179d5c9ce5a7b87b843317c (diff)
downloadlinhes_pkgbuild-2394bb03037c7980d15c21a3224f3ea5874fa2ae.zip
linhes_pkgbuild-2394bb03037c7980d15c21a3224f3ea5874fa2ae.tar.gz
linhes_pkgbuild-2394bb03037c7980d15c21a3224f3ea5874fa2ae.tar.bz2
gnome-desktop: upgrade
Diffstat (limited to 'abs/extra/gnome-desktop')
-rw-r--r--abs/extra/gnome-desktop/PKGBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/abs/extra/gnome-desktop/PKGBUILD b/abs/extra/gnome-desktop/PKGBUILD
index ddd10ad..7c10e8c 100644
--- a/abs/extra/gnome-desktop/PKGBUILD
+++ b/abs/extra/gnome-desktop/PKGBUILD
@@ -1,27 +1,30 @@
-# $Id: PKGBUILD 24727 2009-01-20 10:17:53Z douglas $
+# $Id: PKGBUILD 99767 2010-11-17 12:13:39Z ibiru $
# Maintainer: Jan de Groot <jan@archlinux.org>
pkgname=gnome-desktop
-pkgver=2.24.3
+pkgver=2.32.1
pkgrel=1
pkgdesc="The GNOME Desktop"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
license=('GPL' 'LGPL')
-depends=('libgnomeui>=2.24.0' 'startup-notification>=0.9')
-makedepends=('gnome-doc-utils>=0.14.2' 'pkgconfig' 'intltool')
-optdepends=('gnome-python: gnome-about')
+depends=('gconf>=2.32.0' 'startup-notification>=0.10')
+makedepends=('gnome-doc-utils>=0.20.1' 'intltool')
+optdepends=('pygtk: gnome-about')
url="http://www.gnome.org"
groups=('gnome')
options=('!libtool')
-source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/2.24/${pkgname}-${pkgver}.tar.bz2)
-md5sums=('27579963a56d1d35a22e30c21666a500')
+source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/2.32/${pkgname}-${pkgver}.tar.bz2)
+sha256sums=('55cbecf67efe1fa1e57ac966520a7c46d799c8ba3c652a1219f60cafccb3739d')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --disable-static \
- --with-gnome-distributor="Archlinux" \
- --disable-scrollkeeper || return 1
+ --localstatedir=/var --disable-static \
+ --with-gnome-distributor="Archlinux" \
+ --disable-scrollkeeper
make || return 1
- make DESTDIR="${pkgdir}" install || return 1
+}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}