summaryrefslogtreecommitdiffstats
path: root/abs/extra/htop/htop.c.patch
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2011-10-19 18:31:38 (GMT)
committerJames Meyer <james.meyer@operamail.com>2011-10-19 18:31:38 (GMT)
commitd9aad8b00a9f3fb60e456c0e528df90189acb5b3 (patch)
tree6b9126d2336c62d1e5533798e7348f6a5723f6ba /abs/extra/htop/htop.c.patch
parentd9a08ac22f9c6661cf3b478927be321274d10794 (diff)
parentc65b741914b31ac88086e363edc4415eb6aa1686 (diff)
downloadlinhes_pkgbuild-d9aad8b00a9f3fb60e456c0e528df90189acb5b3.zip
linhes_pkgbuild-d9aad8b00a9f3fb60e456c0e528df90189acb5b3.tar.gz
linhes_pkgbuild-d9aad8b00a9f3fb60e456c0e528df90189acb5b3.tar.bz2
Merge remote-tracking branch 'origin/testing' into testing
Conflicts: abs/core/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/extra/htop/htop.c.patch')
-rw-r--r--abs/extra/htop/htop.c.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/abs/extra/htop/htop.c.patch b/abs/extra/htop/htop.c.patch
new file mode 100644
index 0000000..41a2dd3
--- /dev/null
+++ b/abs/extra/htop/htop.c.patch
@@ -0,0 +1,15 @@
+From: Roman Kosenko <madkite@gmail.com>
+Date: Thu, 10 Mar 2011 16:23:53 +0200
+Subject: [PATCH] Fix stupid bug with --sort-key
+
+--- htop.c.old 2010-11-24 20:45:38.000000000 +0200
++++ htop.c 2011-03-10 16:32:18.473716667 +0200
+@@ -282,7 +282,7 @@
+ printVersionFlag();
+ break;
+ case 's':
+- if (strcmp(optarg, "help")) {
++ if (!strcmp(optarg, "help")) {
+ for (int j = 1; j < LAST_PROCESSFIELD; j++)
+ printf ("%s\n", Process_fieldNames[j]);
+ exit(0);