summaryrefslogtreecommitdiffstats
path: root/abs/extra/icu/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-06 01:06:40 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-06 01:06:40 (GMT)
commitfa050b437f10141db9c28b4f1327d27aa851d944 (patch)
treed46b04d9f727586bcd5db6de05f93030dcf03d1e /abs/extra/icu/PKGBUILD
parent2e9de8e980bd65c44629c8e1cb84105d530ce560 (diff)
parent676db4cdf0ec3a29073ee4408b8a610b1b334bd3 (diff)
downloadlinhes_pkgbuild-fa050b437f10141db9c28b4f1327d27aa851d944.zip
linhes_pkgbuild-fa050b437f10141db9c28b4f1327d27aa851d944.tar.gz
linhes_pkgbuild-fa050b437f10141db9c28b4f1327d27aa851d944.tar.bz2
Merge branch 'testing' of knoppmyth.net:linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/icu/PKGBUILD')
-rw-r--r--abs/extra/icu/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/extra/icu/PKGBUILD b/abs/extra/icu/PKGBUILD
new file mode 100644
index 0000000..14cd4aa
--- /dev/null
+++ b/abs/extra/icu/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 92974 2010-10-02 16:39:18Z andyrtr $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Art Gramlich <art@gramlich-net.com>
+
+pkgname=icu
+pkgver=4.4.2
+pkgrel=1
+pkgdesc="International Components for Unicode library"
+arch=(i686 x86_64)
+url="http://www.icu-project.org/"
+license=('custom:"icu"')
+depends=('gcc-libs' 'sh')
+source=(http://download.icu-project.org/files/${pkgname}4c/${pkgver}/${pkgname}4c-${pkgver//./_}-src.tgz
+ #http://download.icu-project.org/files/${pkgname}4c/${pkgver}/${pkgname}4c-${pkgver/./_}-src.tgz
+)
+md5sums=('314e582264c36b3735466c522899aa07')
+
+
+build() {
+ cd ${srcdir}/icu/source
+ ./configure --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd ${srcdir}/icu/source
+ make -j1 DESTDIR=${pkgdir} install
+
+ # Install license
+ install -Dm644 ${srcdir}/icu/license.html ${pkgdir}/usr/share/licenses/icu/license.html
+}