summaryrefslogtreecommitdiffstats
path: root/abs/extra/kodi-addon-pvr-mythtv/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2019-02-06 23:56:32 (GMT)
committerBritney Fransen <brfransen@gmail.com>2019-02-06 23:56:32 (GMT)
commit417c14d649d2bff64ef03245381845096c671ebb (patch)
tree34998faa4720fbf59d4823a95001cd59c1c32d27 /abs/extra/kodi-addon-pvr-mythtv/PKGBUILD
parent44e83c2380d62397979db59372afb54dfde0b221 (diff)
downloadlinhes_pkgbuild-417c14d649d2bff64ef03245381845096c671ebb.zip
linhes_pkgbuild-417c14d649d2bff64ef03245381845096c671ebb.tar.gz
linhes_pkgbuild-417c14d649d2bff64ef03245381845096c671ebb.tar.bz2
kodi-addon-pvr-mythtv: initial inclusion. replaced kodi-addon-pvr-mythtv-git
Diffstat (limited to 'abs/extra/kodi-addon-pvr-mythtv/PKGBUILD')
-rw-r--r--abs/extra/kodi-addon-pvr-mythtv/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/abs/extra/kodi-addon-pvr-mythtv/PKGBUILD b/abs/extra/kodi-addon-pvr-mythtv/PKGBUILD
new file mode 100644
index 0000000..6a1d8fa
--- /dev/null
+++ b/abs/extra/kodi-addon-pvr-mythtv/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=kodi-addon-pvr-mythtv
+pkgver=5.10.5
+_kodiver=18.0
+_codename=Leia
+pkgrel=1
+pkgdesc='MythTV PVR client addon for Kodi'
+arch=('armv7h' 'i686' 'x86_64')
+url="http://janbar.github.io/pvr.mythtv/"
+license=('GPL')
+makedepends=('cmake' 'git')
+depends=("kodi")
+source=("https://github.com/janbar/pvr.mythtv/archive/${pkgver}-$_codename.tar.gz"
+ "https://github.com/xbmc/xbmc/archive/${_kodiver}-$_codename.tar.gz")
+
+build() {
+ mkdir -p "pvr.mythtv-${pkgver}/build"
+ cd "pvr.mythtv-${pkgver}/build"
+
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DADDONS_TO_BUILD=pvr.mythtv \
+ -DADDONS_SRC_PREFIX=../.. \
+ ../../xbmc-${_kodiver}-$_codename/cmake/addons
+ make
+}
+
+package() {
+ cd "pvr.mythtv-${pkgver}/build/build/depends"
+ install -d "${pkgdir}/usr/lib/kodi/addons/"
+ cp -r ./lib/kodi/addons/pvr.mythtv "${pkgdir}/usr/lib/kodi/addons"
+ install -d "${pkgdir}/usr/share/kodi/addons/"
+ cp -r ./share/kodi/addons/pvr.mythtv "${pkgdir}/usr/share/kodi/addons"
+}
+
+# vim:set ts=2 sw=2 et:
+
+md5sums=('6f76c68fdaa24cb6c5c6fca4a898e554'
+ '010eefd71ffe789dcee0daf0c692123d')