summaryrefslogtreecommitdiffstats
path: root/abs/extra/libass/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2011-08-04 23:37:39 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2011-08-04 23:37:39 (GMT)
commitc883928b0a74db7246bf280d2c6644ccb68f0a81 (patch)
tree7571472b47dc536ccfe469e2ec998ca18a2a28ac /abs/extra/libass/PKGBUILD
parent8ca639078819fb0229652e9feb47c9550fe8747f (diff)
parent7a80bfb7738f90a5232afc3c39f8ded4e9dba21a (diff)
downloadlinhes_pkgbuild-c883928b0a74db7246bf280d2c6644ccb68f0a81.zip
linhes_pkgbuild-c883928b0a74db7246bf280d2c6644ccb68f0a81.tar.gz
linhes_pkgbuild-c883928b0a74db7246bf280d2c6644ccb68f0a81.tar.bz2
Merge branch 'testing' of knoppmyth.net:linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/libass/PKGBUILD')
-rw-r--r--abs/extra/libass/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/extra/libass/PKGBUILD b/abs/extra/libass/PKGBUILD
new file mode 100644
index 0000000..508e232
--- /dev/null
+++ b/abs/extra/libass/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id$
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: G_Syme <demichan(at)mail(dot)upb(dot)de>
+
+pkgname=libass
+pkgver=0.9.13
+pkgrel=1
+pkgdesc="A portable library for SSA/ASS subtitles rendering"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/libass/"
+license=('BSD')
+depends=('enca' 'fontconfig' 'libpng')
+makedepends=('pkgconfig')
+options=(!libtool)
+source=("http://libass.googlecode.com/files/${pkgname}-${pkgver}.tar.xz")
+md5sums=('d99381922dcbeb7a766d2e7825cca193')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}