summaryrefslogtreecommitdiffstats
path: root/abs/extra/libbluray-git
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-10 23:13:08 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-10 23:13:08 (GMT)
commit88c1b84963b442a1d39d8193ce72d17e297f006f (patch)
tree707179173751bff29a018a403dbed4923db47985 /abs/extra/libbluray-git
parentbf347ccc26e6d65950cea72b1990dbf8c9fe98c1 (diff)
parent7921961814dea89fbf846d06095afd207c8dfd23 (diff)
downloadlinhes_pkgbuild-88c1b84963b442a1d39d8193ce72d17e297f006f.zip
linhes_pkgbuild-88c1b84963b442a1d39d8193ce72d17e297f006f.tar.gz
linhes_pkgbuild-88c1b84963b442a1d39d8193ce72d17e297f006f.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/libbluray-git')
-rw-r--r--abs/extra/libbluray-git/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/abs/extra/libbluray-git/PKGBUILD b/abs/extra/libbluray-git/PKGBUILD
new file mode 100644
index 0000000..c83dce3
--- /dev/null
+++ b/abs/extra/libbluray-git/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Andrew Cook <ariscop@gmail.com>
+
+pkgname=libbluray-git
+pkgver=20101110
+pkgrel=1
+pkgdesc="Blu-Ray access library"
+arch=('i686' 'x86_64')
+depends=('doxygen')
+license=('LGPL')
+url="http://www.videolan.org/developers/libbluray.html"
+makedepends=('git')
+source=()
+md5sums=()
+provides=('libbluray')
+conflicts=('libbluray')
+
+_gitroot="git://git.videolan.org/libbluray.git"
+_gitname="libbluray"
+
+build() {
+ msg "Connecting to GIT server..."
+
+ if [ -d ${srcdir}/$_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ cd ${srcdir}/libbluray
+ ./bootstrap
+ ./configure --prefix=/
+ make || return 1
+ make DESTDIR=${pkgdir}/usr install || return 1
+}