summaryrefslogtreecommitdiffstats
path: root/abs/extra/libcrystalhd-git
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-06 17:34:48 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-06 17:34:48 (GMT)
commita88e0a4caaee4269707417416f8e36c754ea6e16 (patch)
treede63f290d0c85422f5c9bb8bfb3e186030f79080 /abs/extra/libcrystalhd-git
parent9b21e2c89af805f7e2e3014075318587ae479396 (diff)
parent28df92c527607da6a77cbc2ba0f8f62bc6dff548 (diff)
downloadlinhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.zip
linhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.tar.gz
linhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/libcrystalhd-git')
-rw-r--r--abs/extra/libcrystalhd-git/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/abs/extra/libcrystalhd-git/PKGBUILD b/abs/extra/libcrystalhd-git/PKGBUILD
new file mode 100644
index 0000000..27d8fff
--- /dev/null
+++ b/abs/extra/libcrystalhd-git/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Petteri Tolonen <petteri.tolonen@gmail.com>
+pkgname=libcrystalhd-git
+pkgver=`date +%Y%m%d`
+pkgrel=1
+pkgdesc="Broadcom Crystal HD library from git.wilsonet.com"
+arch=('i686' 'x86_64')
+url="http://git.wilsonet.com/crystalhd.git/"
+license=('GPL2')
+depends=('gcc-libs')
+makedepends=('git' 'make')
+conflicts=('libcrystalhd')
+
+_gitroot='git://git.wilsonet.com/crystalhd.git'
+_gitname='crystalhd'
+
+build() {
+
+ cd $startdir/src
+
+ msg "Connecting to git.wilsonet.com GIT server...."
+
+ if [ -d $startdir/src/$_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ cd $_gitname
+ fi
+
+ cd linux_lib/libcrystalhd
+
+ make || return 1
+ make install DESTDIR=$pkgdir || return 1
+
+}