summaryrefslogtreecommitdiffstats
path: root/abs/extra/libdvdnav
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-10 03:45:51 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-10 03:45:51 (GMT)
commit557603f4844b7c811644c4cca665cd8068fcea2d (patch)
treee0ddb042c3a52f943ee142fce23531d5accc2385 /abs/extra/libdvdnav
parent73332958e0b6c3578829fb91e03e270cc1948fcb (diff)
downloadlinhes_pkgbuild-557603f4844b7c811644c4cca665cd8068fcea2d.zip
linhes_pkgbuild-557603f4844b7c811644c4cca665cd8068fcea2d.tar.gz
linhes_pkgbuild-557603f4844b7c811644c4cca665cd8068fcea2d.tar.bz2
libdvdnav: update to latest
Diffstat (limited to 'abs/extra/libdvdnav')
-rw-r--r--abs/extra/libdvdnav/PKGBUILD26
-rw-r--r--abs/extra/libdvdnav/deadlock.patch17
2 files changed, 34 insertions, 9 deletions
diff --git a/abs/extra/libdvdnav/PKGBUILD b/abs/extra/libdvdnav/PKGBUILD
index 4e9e3ca..67c56e4 100644
--- a/abs/extra/libdvdnav/PKGBUILD
+++ b/abs/extra/libdvdnav/PKGBUILD
@@ -1,22 +1,30 @@
-# $Id: PKGBUILD 927 2008-04-24 21:34:43Z jgc $
+# $Id: PKGBUILD 69820 2010-02-22 22:23:44Z giovanni $
# Maintainer: arjan <arjan@archlinux.org>
# contributor Sarah Hay <sarahhay@mb.sympatico.ca>
pkgname=libdvdnav
-pkgver=0.1.10
-pkgrel=3
+pkgver=4.1.3
+pkgrel=2
pkgdesc="The library for xine-dvdnav plugin."
arch=(i686 x86_64)
license=('GPL')
-url="http://dvd.sourceforge.net/index.shtml"
-depends=('glibc')
+url="http://www.mplayerhq.hu/MPlayer/releases/dvdnav/"
+depends=('libdvdread>=4.1.3')
options=(!libtool)
-source=(http://downloads.sourceforge.net/sourceforge/dvd/${pkgname}-${pkgver}.tar.gz)
-md5sums=('c8ddee96ba1182d73447eaf0bb6fde81')
+source=(http://www.mplayerhq.hu/MPlayer/releases/dvdnav/${pkgname}-${pkgver}.tar.bz2
+ deadlock.patch)
+md5sums=('d62383c45b28816771e283515f2c27fa'
+ '864529165a1136ae4c1ccbc7b43cdb1a')
build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -Np1 -i ${srcdir}/deadlock.patch || return 1
+
./autogen.sh --prefix=/usr || return 1
make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
+ make DESTDIR="${pkgdir}" install || return 1
}
+
+md5sums=('d62383c45b28816771e283515f2c27fa'
+ 'd26d9ab9d705e4e3fa16e0592ad33c79')
diff --git a/abs/extra/libdvdnav/deadlock.patch b/abs/extra/libdvdnav/deadlock.patch
new file mode 100644
index 0000000..2a58240
--- /dev/null
+++ b/abs/extra/libdvdnav/deadlock.patch
@@ -0,0 +1,17 @@
+--- a/src/dvdnav.c 2009-11-08 16:58:25.000000000 +0300
++++ b/src/dvdnav.c 2009-11-08 16:58:52.000000000 +0300
+@@ -180,12 +180,13 @@
+ pthread_mutex_unlock(&this->vm_lock);
+ return DVDNAV_STATUS_ERR;
+ }
++ pthread_mutex_unlock(&this->vm_lock);
++
+ #ifdef LOG_DEBUG
+ fprintf(MSG_OUT, "libdvdnav: clearing dvdnav\n");
+ #endif
+ result = dvdnav_clear(this);
+
+- pthread_mutex_unlock(&this->vm_lock);
+ return result;
+ }
+