summaryrefslogtreecommitdiffstats
path: root/abs/extra/libnl/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2011-11-04 18:32:24 (GMT)
committerJames Meyer <james.meyer@operamail.com>2011-11-04 18:32:24 (GMT)
commitb7aec163ffacbe0c25399e2b832ce11fc17b31e6 (patch)
tree3585d14cd7993d425f81c7d8e49a80b20433b63c /abs/extra/libnl/PKGBUILD
parenta6c667c3705505ee5a9917841dd398796809f980 (diff)
parent849d0e10eee0b380be946af140e3ea93b3c3a461 (diff)
downloadlinhes_pkgbuild-b7aec163ffacbe0c25399e2b832ce11fc17b31e6.zip
linhes_pkgbuild-b7aec163ffacbe0c25399e2b832ce11fc17b31e6.tar.gz
linhes_pkgbuild-b7aec163ffacbe0c25399e2b832ce11fc17b31e6.tar.bz2
Merge branch 'testing' of ssh://jams@linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/libnl/PKGBUILD')
-rw-r--r--abs/extra/libnl/PKGBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/abs/extra/libnl/PKGBUILD b/abs/extra/libnl/PKGBUILD
index 4a6465a..8136059 100644
--- a/abs/extra/libnl/PKGBUILD
+++ b/abs/extra/libnl/PKGBUILD
@@ -1,21 +1,28 @@
-# $Id: PKGBUILD 930 2008-04-24 22:14:40Z jgc $
+# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: William Rea <sillywilly@gmail.com>
+
pkgname=libnl
pkgver=1.1
-pkgrel=2
+pkgrel=3
pkgdesc="Library for applications dealing with netlink sockets"
arch=('i686' 'x86_64')
-url="http://people.suug.ch/~tgr/libnl"
+url="http://www.infradead.org/~tgr/libnl/"
license=('GPL')
depends=('glibc')
-source=(http://people.suug.ch/~tgr/${pkgname}/files/${pkgname}-${pkgver}.tar.gz ulong_max.patch)
-md5sums=('ae970ccd9144e132b68664f98e7ceeb1' '255bb3740149d518766032675810c590')
+source=("http://www.infradead.org/~tgr/libnl/files/${pkgname}-${pkgver}.tar.gz"
+ 'fix-compilation.patch')
build() {
- cd ${startdir}/src/libnl-${pkgver}
- patch -p1 < ../ulong_max.patch
- ./configure --prefix=/usr || return 1
- make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
+ cd ${srcdir}/libnl-${pkgver}
+ patch -Np1 -i ${srcdir}/fix-compilation.patch
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/libnl-${pkgver}
+ make DESTDIR=${pkgdir} install
}
+md5sums=('ae970ccd9144e132b68664f98e7ceeb1'
+ '2490289a9edcc5c03802d151bcf3acc4')