summaryrefslogtreecommitdiffstats
path: root/abs/extra/libnl/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2011-11-04 18:17:57 (GMT)
committerBritney Fransen <brfransen@gmail.com>2011-11-04 18:17:57 (GMT)
commitd8240dbd2af91d4c08c5a379ab58045bdaacabce (patch)
tree8e7d7bb705f8c691f4cb59b07e1961386cd77f7e /abs/extra/libnl/PKGBUILD
parent4a4f6c0f7a1b24045604f13186ddda45213d0209 (diff)
downloadlinhes_pkgbuild-d8240dbd2af91d4c08c5a379ab58045bdaacabce.zip
linhes_pkgbuild-d8240dbd2af91d4c08c5a379ab58045bdaacabce.tar.gz
linhes_pkgbuild-d8240dbd2af91d4c08c5a379ab58045bdaacabce.tar.bz2
libnl: update to latest
Diffstat (limited to 'abs/extra/libnl/PKGBUILD')
-rw-r--r--abs/extra/libnl/PKGBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/abs/extra/libnl/PKGBUILD b/abs/extra/libnl/PKGBUILD
index 4a6465a..8136059 100644
--- a/abs/extra/libnl/PKGBUILD
+++ b/abs/extra/libnl/PKGBUILD
@@ -1,21 +1,28 @@
-# $Id: PKGBUILD 930 2008-04-24 22:14:40Z jgc $
+# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: William Rea <sillywilly@gmail.com>
+
pkgname=libnl
pkgver=1.1
-pkgrel=2
+pkgrel=3
pkgdesc="Library for applications dealing with netlink sockets"
arch=('i686' 'x86_64')
-url="http://people.suug.ch/~tgr/libnl"
+url="http://www.infradead.org/~tgr/libnl/"
license=('GPL')
depends=('glibc')
-source=(http://people.suug.ch/~tgr/${pkgname}/files/${pkgname}-${pkgver}.tar.gz ulong_max.patch)
-md5sums=('ae970ccd9144e132b68664f98e7ceeb1' '255bb3740149d518766032675810c590')
+source=("http://www.infradead.org/~tgr/libnl/files/${pkgname}-${pkgver}.tar.gz"
+ 'fix-compilation.patch')
build() {
- cd ${startdir}/src/libnl-${pkgver}
- patch -p1 < ../ulong_max.patch
- ./configure --prefix=/usr || return 1
- make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
+ cd ${srcdir}/libnl-${pkgver}
+ patch -Np1 -i ${srcdir}/fix-compilation.patch
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/libnl-${pkgver}
+ make DESTDIR=${pkgdir} install
}
+md5sums=('ae970ccd9144e132b68664f98e7ceeb1'
+ '2490289a9edcc5c03802d151bcf3acc4')