summaryrefslogtreecommitdiffstats
path: root/abs/extra/libproxy
diff options
context:
space:
mode:
authorJames Meyer <jams@linhes.org>2010-12-29 00:53:57 (GMT)
committerJames Meyer <jams@linhes.org>2010-12-29 00:53:57 (GMT)
commitbfbb65a6f8708052a18dd08bb8a3b5c5805a3e8d (patch)
tree8641b9762f43e4ee1022643782d013d7bdc06143 /abs/extra/libproxy
parent082e88179d8a355d5e67e62c5031d3d689ea3d5b (diff)
parenteb0b8a2e6a2b8c78266e2e641a468843deee61c3 (diff)
downloadlinhes_pkgbuild-bfbb65a6f8708052a18dd08bb8a3b5c5805a3e8d.zip
linhes_pkgbuild-bfbb65a6f8708052a18dd08bb8a3b5c5805a3e8d.tar.gz
linhes_pkgbuild-bfbb65a6f8708052a18dd08bb8a3b5c5805a3e8d.tar.bz2
Merge remote branch 'origin/testing' into testing
Diffstat (limited to 'abs/extra/libproxy')
-rw-r--r--abs/extra/libproxy/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/abs/extra/libproxy/PKGBUILD b/abs/extra/libproxy/PKGBUILD
new file mode 100644
index 0000000..2f2010e
--- /dev/null
+++ b/abs/extra/libproxy/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 24494 2009-01-17 20:42:01Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libproxy
+pkgver=0.4.6
+pkgrel=2
+pkgdesc="A library that provides automatic proxy configuration management"
+arch=(i686 x86_64)
+license=('LGPL')
+depends=('gcc-libs')
+optdepends=('gconf: GNOME configuration module'
+ 'kdelibs: KDE configuration module'
+ 'networkmanager: NetworkManager configuration module'
+ 'libwebkit: WPAD/PAC parsing via WebKit JavaScript engine'
+ 'xulrunner: WPAD/PAC parsing via Mozilla JavaScript engine'
+ 'perl: Perl bindings'
+ 'python2: Python bindings')
+makedepends=('xulrunner' 'gconf' 'cmake' 'networkmanager' 'libwebkit' 'automoc4' 'python2' 'kdelibs' 'perl')
+url="http://libproxy.googlecode.com"
+source=(http://libproxy.googlecode.com/files/${pkgname}-${pkgver}.tar.gz)
+options=('!libtool')
+md5sums=('199c6b120baf1f7258a55f38d5ec74f5')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIBEXEC_INSTALL_DIR=/usr/lib/libproxy \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DPERL_VENDORINSTALL=yes \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS}" \
+ -DCMAKE_C_FLAGS="${CFLAGS}" \
+ ..
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+ make DESTDIR="${pkgdir}" install
+}