summaryrefslogtreecommitdiffstats
path: root/abs/extra/libshout
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2011-02-13 00:42:05 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2011-02-13 00:42:05 (GMT)
commit46d122a9a53c1a38980f018489de9f33c4299151 (patch)
tree18cb76e6deeab07007ca68dbe10fe7c6bc0fa886 /abs/extra/libshout
parenta54153dd7dffedda0ec01c5f21d1640d125afa47 (diff)
parentcf8226bb36fcad78ee6fee881c02c655e9bcfd25 (diff)
downloadlinhes_pkgbuild-46d122a9a53c1a38980f018489de9f33c4299151.zip
linhes_pkgbuild-46d122a9a53c1a38980f018489de9f33c4299151.tar.gz
linhes_pkgbuild-46d122a9a53c1a38980f018489de9f33c4299151.tar.bz2
Merge branch 'testing' of knoppmyth.net:linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/libshout')
-rw-r--r--abs/extra/libshout/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra/libshout/PKGBUILD b/abs/extra/libshout/PKGBUILD
new file mode 100644
index 0000000..8c03bbc
--- /dev/null
+++ b/abs/extra/libshout/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 37200 2009-05-01 03:37:50Z eric $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: arjan <arjan@archlinux.org>
+# Contributor: Jason Chu <jchu@xentac.net>
+
+pkgname=libshout
+pkgver=2.2.2
+pkgrel=3
+pkgdesc="Library for accessing a shoutcast/icecast server"
+arch=('i686' 'x86_64')
+depends=('libvorbis' 'libtheora' 'speex')
+url="http://www.icecast.org/"
+options=('!libtool' 'force')
+license=('LGPL')
+source=(http://downloads.xiph.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('4f75fc9901c724b712c371c9a1e782d3')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var || return 1
+ make LDFLAGS+=-lspeex || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+}