summaryrefslogtreecommitdiffstats
path: root/abs/extra/libupnp/PKGBUILD
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-07-06 02:03:45 (GMT)
committerCecil <knoppmyth@gmail.com>2011-07-06 02:03:45 (GMT)
commita54f8539565e8523c35774ae42bf14e80fec8184 (patch)
tree81cbe14e4fb581fbed89b0facd2b26e1b89caf80 /abs/extra/libupnp/PKGBUILD
parent3ecceb27a3143bb3d7875f001cad8018211206ba (diff)
parent9d22bcc9fb43b439a789dd0e6adef20b017aa921 (diff)
downloadlinhes_pkgbuild-a54f8539565e8523c35774ae42bf14e80fec8184.zip
linhes_pkgbuild-a54f8539565e8523c35774ae42bf14e80fec8184.tar.gz
linhes_pkgbuild-a54f8539565e8523c35774ae42bf14e80fec8184.tar.bz2
Merge branch 'testing' of ssh://cesman@linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/libupnp/PKGBUILD')
-rw-r--r--abs/extra/libupnp/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/extra/libupnp/PKGBUILD b/abs/extra/libupnp/PKGBUILD
new file mode 100644
index 0000000..39cfef7
--- /dev/null
+++ b/abs/extra/libupnp/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id$
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: kastor <kastor@fobos.org.ar>
+
+pkgname=libupnp
+pkgver=1.6.13
+pkgrel=1
+pkgdesc="Portable Open Source UPnP Development Kit"
+arch=('i686' 'x86_64')
+url="http://pupnp.sourceforge.net/"
+license=('BSD')
+depends=('glibc')
+makedepends=('pkgconfig')
+options=('!libtool')
+source=("http://downloads.sourceforge.net/sourceforge/pupnp/${pkgname}-${pkgver}.tar.bz2")
+md5sums=('71476b1781ad179bfc9bead640be5f54')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR=${pkgdir} install
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/custom/${pkgname}/LICENSE
+}
+