summaryrefslogtreecommitdiffstats
path: root/abs/extra/miro
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/extra/miro
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/extra/miro')
-rw-r--r--abs/extra/miro/ChangeLog34
-rw-r--r--abs/extra/miro/Changelog2
-rw-r--r--abs/extra/miro/Miro-xulrunner.patch64
-rw-r--r--abs/extra/miro/PKGBUILD32
-rw-r--r--abs/extra/miro/boost_1.36.0_fix.patch32
-rw-r--r--abs/extra/miro/miro-xine.patch12
-rw-r--r--abs/extra/miro/miro.exec.patch9
-rw-r--r--abs/extra/miro/miro.install54
-rw-r--r--abs/extra/miro/miro_python26.patch16
-rw-r--r--abs/extra/miro/missing-headers.patch33
10 files changed, 288 insertions, 0 deletions
diff --git a/abs/extra/miro/ChangeLog b/abs/extra/miro/ChangeLog
new file mode 100644
index 0000000..223b1de
--- /dev/null
+++ b/abs/extra/miro/ChangeLog
@@ -0,0 +1,34 @@
+2008-01-30 Eric Belanger <eric@archlinux.org>
+ * miro-1.1-2
+ * rebuilt against xulrunner 1.8.1.11
+
+2008-01-16 Varun Acharya <varun@archlinux.org>
+
+ * upgpkg miro-1.1
+
+2008-01-03 Varun Acharya <varun@archlinux.org>
+
+ * Adopted and moved to extra, miro-1.0-2
+
+2007-11-26 Alessio 'mOLOk' Bolognino <themolok@gmail.com>
+
+ * miro-1.0-2
+ * changed url
+ * added sqlite3 as dep (fix FS#8636)
+
+2007-11-13 Alessio 'mOLOk' Bolognino <themolok@gmail.com>
+
+ * miro-1.0-1
+ * version bump
+
+2007-09-09 Alessio 'mOLOk' Bolognino <themolok@gmail.com>
+
+ * miro-0.9.9-1
+ * version bump
+
+2007-08-08 Alessio 'mOLOk' Bolognino <themolok@gmail.com>
+
+ * miro-0.9.8.1-1
+ * initial commit
+
+
diff --git a/abs/extra/miro/Changelog b/abs/extra/miro/Changelog
new file mode 100644
index 0000000..40505f2
--- /dev/null
+++ b/abs/extra/miro/Changelog
@@ -0,0 +1,2 @@
+Miro 2.0.4-3 4/30/09
+Upgrade miro.install to add remove miro from is.xml.
diff --git a/abs/extra/miro/Miro-xulrunner.patch b/abs/extra/miro/Miro-xulrunner.patch
new file mode 100644
index 0000000..b8f4db3
--- /dev/null
+++ b/abs/extra/miro/Miro-xulrunner.patch
@@ -0,0 +1,64 @@
+diff -up Miro-1.2.3/platform/gtk-x11/platform/mozsetup.py.old Miro-1.2.3/platform/gtk-x11/platform/mozsetup.py
+--- Miro-1.2.3/platform/gtk-x11/platform/mozsetup.py.old 2008-04-22 17:17:01.000000000 +0200
++++ Miro-1.2.3/platform/gtk-x11/platform/mozsetup.py 2008-04-28 12:51:46.000000000 +0200
+@@ -106,8 +106,8 @@ def setupMozillaEnvironment():
+ set_profile_path = gtkmozembed.gtk_moz_embed_set_profile_path
+
+ set_profile_path(config.get(prefs.SUPPORT_DIRECTORY), 'mozilla')
+- if hasattr(gtkmozembed, 'set_comp_path'):
+- set_comp_path = gtkmozembed.set_comp_path
++ if hasattr(gtkmozembed, 'set_path'):
++ set_comp_path = gtkmozembed.set_path
+ elif hasattr(gtkmozembed, 'set_path'):
+ set_comp_path = gtkmozembed.set_path
+ else:
+diff -up Miro-1.2.3/platform/gtk-x11/setup.py.old Miro-1.2.3/platform/gtk-x11/setup.py
+--- Miro-1.2.3/platform/gtk-x11/setup.py.old 2008-04-22 17:17:01.000000000 +0200
++++ Miro-1.2.3/platform/gtk-x11/setup.py 2008-04-28 13:14:27.000000000 +0200
+@@ -209,6 +209,7 @@ def parsePkgConfig(command, components,
+ options_dict = {
+ 'include_dirs' : [],
+ 'library_dirs' : [],
++ 'runtime_dirs' : [],
+ 'libraries' : [],
+ 'extra_compile_args' : []
+ }
+@@ -224,6 +225,11 @@ def parsePkgConfig(command, components,
+ options_dict['libraries'].append(rest)
+ else:
+ options_dict['extra_compile_args'].append(comp)
++
++ commandLine = "%s --variable=libdir %s" % (command, components)
++ output = getCommandOutput(commandLine).strip()
++ options_dict['runtime_dirs'].append(output)
++
+ return options_dict
+
+ #### The fasttypes extension ####
+@@ -279,6 +285,8 @@ mozilla_browser_options = parsePkgConfig
+ "gtk+-2.0 glib-2.0 pygtk-2.0 --define-variable=includetype=unstable %s %s" % (gtkmozembed, xpcom))
+ mozilla_lib_path = parsePkgConfig('pkg-config',
+ '%s' % gtkmozembed)['library_dirs']
++runtime_lib_path = parsePkgConfig('pkg-config',
++ '%s' % gtkmozembed)['runtime_dirs']
+ # Find the base mozilla directory, and add the subdirs we need.
+ def allInDir(directory, subdirs):
+ for subdir in subdirs:
+@@ -334,7 +342,7 @@ mozilla_browser_ext = Extension("miro.pl
+ os.path.join(platform_html_frontend_dir,'DragAndDrop.cc'),
+ os.path.join(platform_html_frontend_dir,'XPCOMUtil.cc'),
+ ],
+- runtime_library_dirs=mozilla_lib_path,
++ runtime_library_dirs=runtime_lib_path,
+ **mozilla_browser_options)
+ #### Xlib Extension ####
+ xlib_ext = \
+@@ -434,7 +442,7 @@ class install_data (distutils.command.in
+ BUILD_MACHINE="%s@%s" % (getlogin(),
+ os.uname()[1]),
+ BUILD_TIME=str(time.time()),
+- MOZILLA_LIB_PATH=mozilla_lib_path[0])
++ MOZILLA_LIB_PATH=runtime_lib_path[0])
+ self.outfiles.append(dest)
+
+ locale_dir = os.path.join (resource_dir, "locale")
diff --git a/abs/extra/miro/PKGBUILD b/abs/extra/miro/PKGBUILD
new file mode 100644
index 0000000..1411c43
--- /dev/null
+++ b/abs/extra/miro/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 35621 2009-04-14 18:07:17Z ronald $
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+
+pkgname=miro
+pkgver=2.0.4
+pkgrel=9
+pkgdesc="The free and open source internet TV platform"
+arch=('i686' 'x86_64')
+url="http://www.getmiro.com"
+license=('GPL2')
+depends=('xine-lib>=1.1.16.1' 'boost>=1.37.0' 'gnome-python-extras>=2.25.3'
+ 'dbus-python>=0.82.4' 'pyrex' 'xulrunner>=1.9.0.1' 'gtk2' 'nspr'
+ 'desktop-file-utils')
+makedepends=('pkgconfig' 'pm-utils' 'qt3')
+optdepends=('gstreamer0.10-python: gstreamer backend (potentially unstable)' 'gstreamer0.10: gstreamer backend (potentially unstable')
+install=miro.install
+conflicts=('democracy')
+replaces=('democracy')
+provides=('democracy')
+source=(http://ftp.osuosl.org/pub/pculture.org/miro/src/Miro-${pkgver}.tar.gz
+ miro.exec.patch)
+md5sums=('e6cf48252496b2bddd290f375fc0ca33'
+ '355648eac790d52c51ccb014736f90fc')
+
+build() {
+ cd ${srcdir}/Miro-${pkgver}/platform/gtk-x11
+ python setup.py install --root=${pkgdir} || return 1
+
+ # Fix FS#14196
+ cd ${pkgdir}
+ patch -Np0 -i ${srcdir}/miro.exec.patch || return 1
+}
diff --git a/abs/extra/miro/boost_1.36.0_fix.patch b/abs/extra/miro/boost_1.36.0_fix.patch
new file mode 100644
index 0000000..b3b5a48
--- /dev/null
+++ b/abs/extra/miro/boost_1.36.0_fix.patch
@@ -0,0 +1,32 @@
+--- Miro-1.2.7/portable/libtorrent/src/torrent_info.cpp.old 2008-09-21 13:47:00.122974031 +0200
++++ Miro-1.2.7/portable/libtorrent/src/torrent_info.cpp 2008-09-21 13:48:54.812965713 +0200
+@@ -352,7 +352,7 @@
+ fs::path tmp = m_name;
+ if (tmp.is_complete()) throw std::runtime_error("torrent contains "
+ "a file with an absolute path: '" + m_name + "'");
+- if (tmp.has_branch_path()) throw std::runtime_error(
++ if (!tmp.branch_path().empty()) throw std::runtime_error(
+ "torrent contains name with directories: '" + m_name + "'");
+
+ // extract file list
+@@ -556,7 +556,7 @@
+ {
+ // TORRENT_ASSERT(file.begin() != file.end());
+
+- if (!file.has_branch_path())
++ if (file.branch_path().empty())
+ {
+ // you have already added at least one file with a
+ // path to the file (branch_path), which means that
+
+--- Miro-1.2.7/portable/libtorrent/include/libtorrent/disk_io_thread.hpp.old 2008-09-21 13:57:05.433330334 +0200
++++ Miro-1.2.7/portable/libtorrent/include/libtorrent/disk_io_thread.hpp 2008-09-21 13:57:29.060304305 +0200
+@@ -41,6 +41,7 @@
+ #include <boost/bind.hpp>
+ #include <boost/pool/pool.hpp>
+ #include <boost/noncopyable.hpp>
++#include <boost/thread/condition.hpp>
+ #include "libtorrent/config.hpp"
+
+ namespace libtorrent
+
diff --git a/abs/extra/miro/miro-xine.patch b/abs/extra/miro/miro-xine.patch
new file mode 100644
index 0000000..5abf5f1
--- /dev/null
+++ b/abs/extra/miro/miro-xine.patch
@@ -0,0 +1,12 @@
+--- usr/bin/miro.old 2009-02-22 21:49:26.332356738 +0100
++++ usr/bin/miro 2009-02-22 21:50:39.169010435 +0100
+@@ -21,7 +21,7 @@
+ exit;
+ fi
+
+- LD_LIBRARY_PATH=/usr/lib/xulrunner-1.9 $GDB -ex 'set breakpoint pending on' -ex 'break gdk_x_error' -ex 'run' --args $PYTHON ./miro.real --sync "$@"
++ LD_LIBRARY_PATH=/usr/lib/xulrunner-1.9 $GDB -ex 'set breakpoint pending on' -ex 'break gdk_x_error' -ex 'run' --args $PYTHON ./miro.real --set xine-driver=opengl --sync "$@"
+ else
+- LD_LIBRARY_PATH=/usr/lib/xulrunner-1.9 miro.real "$@"
++ LD_LIBRARY_PATH=/usr/lib/xulrunner-1.9 miro.real --set xine-driver=opengl "$@"
+ fi
diff --git a/abs/extra/miro/miro.exec.patch b/abs/extra/miro/miro.exec.patch
new file mode 100644
index 0000000..4b012af
--- /dev/null
+++ b/abs/extra/miro/miro.exec.patch
@@ -0,0 +1,9 @@
+--- usr/bin/miro.old 2009-04-14 19:40:09.578785938 +0200
++++ usr/bin/miro 2009-04-14 19:40:34.445435006 +0200
+@@ -23,5 +23,5 @@
+
+ LD_LIBRARY_PATH=/usr/lib/xulrunner-1.9 $GDB -ex 'set breakpoint pending on' -ex 'run' --args $PYTHON ./miro.real --sync "$@"
+ else
+- LD_LIBRARY_PATH=/usr/lib/xulrunner-1.9 miro.real "$@"
++ MOZILLA_FIVE_HOME="/usr/lib/xulrunner-1.9/" LD_LIBRARY_PATH=/usr/lib/xulrunner-1.9 miro.real "$@"
+ fi
diff --git a/abs/extra/miro/miro.install b/abs/extra/miro/miro.install
new file mode 100644
index 0000000..db52df4
--- /dev/null
+++ b/abs/extra/miro/miro.install
@@ -0,0 +1,54 @@
+# arg 1: the new package version
+post_install() {
+ update-desktop-database -q
+ mv /usr/share/mythtv/is.xml /tmp/is.xml.tmp
+ sed -e '/\#Miro/,/\#Miro/d' < /tmp/is.xml.tmp > /usr/share/mythtv/is.xml
+ mv /usr/share/mythtv/is.xml /tmp
+ grep -v -e /mythmenu /tmp/is.xml > /tmp/is.xml.tmp
+ echo "<!--#Miro-->" >> /tmp/is.xml.tmp
+ echo " <button>" >> /tmp/is.xml.tmp
+ echo " <type>STREAM</type>" >> /tmp/is.xml.tmp
+ echo " <text>Miro Player</text>" >> /tmp/is.xml.tmp
+ echo " <action>EXEC /usr/bin/miro --set xine-xvhack=false --set renderer=xine</action>" >> /tmp/is.xml.tmp
+ echo " </button>" >> /tmp/is.xml.tmp
+ echo "<!--#Miro-->" >> /tmp/is.xml.tmp
+ echo "" >> /tmp/is.xml.tmp
+ echo "</mythmenu>" >> /tmp/is.xml.tmp
+ mv /tmp/is.xml.tmp /usr/share/mythtv/is.xml
+ if [ -d /myth/democracy ]
+ then
+ ln -s /myth/democracy /home/mythtv/.miro
+ ln -s /myth/miro/Movies /myth/video/Miro
+ exit 1
+ else
+ if [ -d /myth/miro ]
+ then
+ ln -s /myth/miro /home/mythtv/.miro
+ ln -s /myth/miro/Movies /myth/video/Miro
+ exit 1
+ else
+ if [ ! -d /myth/miro -o /myth/democracy ]
+ then
+ mkdir -p /myth/miro/Movies
+ ln -s /myth/miro /home/mythtv/.miro
+ ln -s /myth/miro/Movies /home/mythtv/Movies
+ ln -s /myth/miro/Movies /myth/video/Miro
+ fi
+ fi
+ fi
+}
+
+post_update() {
+ post_install $1
+}
+
+post_remove() {
+ update-desktop-database -q
+ rm -fr /home/mythtv/.miro /myth/video/Miro /myth/miro /myth/democracy
+ mv /usr/share/mythtv/is.xml /tmp/is.xml.tmp
+ sed -e '/\#Miro/,/\#Miro/d' < /tmp/is.xml.tmp > /usr/share/mythtv/is.xml
+}
+
+op=$1
+shift
+$op $*
diff --git a/abs/extra/miro/miro_python26.patch b/abs/extra/miro/miro_python26.patch
new file mode 100644
index 0000000..f404a4e
--- /dev/null
+++ b/abs/extra/miro/miro_python26.patch
@@ -0,0 +1,16 @@
+--- miro.real 2008-10-24 19:49:17.000000000 +0200
++++ miro.real.new 2008-11-12 08:51:17.649458321 +0100
+@@ -6,8 +6,12 @@
+ if xlibhelper.XInitThreads() == 0:
+ print "WARNING: XInitThreads() failed!"
+
+-import os.path
++import miro.feedparser
++import miro.storedatabase
+ import sys
++sys.modules['feedparser'] = miro.feedparser
++sys.modules['storedatabase'] = miro.storedatabase
++import os.path
+ import optparse
+
+ import pygtk
diff --git a/abs/extra/miro/missing-headers.patch b/abs/extra/miro/missing-headers.patch
new file mode 100644
index 0000000..7dc42b8
--- /dev/null
+++ b/abs/extra/miro/missing-headers.patch
@@ -0,0 +1,33 @@
+diff -ur a/portable/libtorrent/include/libtorrent/peer_id.hpp b/portable/libtorrent/include/libtorrent/peer_id.hpp
+--- a/portable/libtorrent/include/libtorrent/peer_id.hpp 2008-04-22 10:17:04.000000000 -0500
++++ b/portable/libtorrent/include/libtorrent/peer_id.hpp 2008-05-07 01:51:09.000000000 -0500
+@@ -38,6 +38,7 @@
+ #include <cctype>
+ #include <algorithm>
+ #include <string>
++#include <cstring>
+
+ #include "libtorrent/config.hpp"
+ #include "libtorrent/assert.hpp"
+diff -ur a/portable/libtorrent/src/entry.cpp b/portable/libtorrent/src/entry.cpp
+--- a/portable/libtorrent/src/entry.cpp 2008-04-22 10:17:04.000000000 -0500
++++ b/portable/libtorrent/src/entry.cpp 2008-05-07 02:16:14.000000000 -0500
+@@ -33,6 +33,7 @@
+ #include "libtorrent/pch.hpp"
+
+ #include <algorithm>
++#include <iostream>
+ #include <iomanip>
+ #include "libtorrent/entry.hpp"
+ #include "libtorrent/config.hpp"
+diff -ur a/portable/libtorrent/src/file.cpp b/portable/libtorrent/src/file.cpp
+--- a/portable/libtorrent/src/file.cpp 2008-04-22 10:17:04.000000000 -0500
++++ b/portable/libtorrent/src/file.cpp 2008-05-07 01:53:04.000000000 -0500
+@@ -68,6 +68,7 @@
+ #include <boost/filesystem/operations.hpp>
+ #include "libtorrent/file.hpp"
+ #include <sstream>
++#include <cstring>
+
+ #ifndef O_BINARY
+ #define O_BINARY 0