summaryrefslogtreecommitdiffstats
path: root/abs/extra/monitorix/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <jams@linhes.org>2010-12-04 23:48:49 (GMT)
committerJames Meyer <jams@linhes.org>2010-12-04 23:48:49 (GMT)
commit037ab1a6a2fee07c83b47dc4d4ffd629b9052e85 (patch)
treea4256da38a768da362aad34ad9a8bcc7da611c30 /abs/extra/monitorix/PKGBUILD
parent0b251e4b5f6d56e5aba84aaf780fbf4e6a289245 (diff)
parent2ddfcdc1360af607e5925afe0e0f3562ad538738 (diff)
downloadlinhes_pkgbuild-037ab1a6a2fee07c83b47dc4d4ffd629b9052e85.zip
linhes_pkgbuild-037ab1a6a2fee07c83b47dc4d4ffd629b9052e85.tar.gz
linhes_pkgbuild-037ab1a6a2fee07c83b47dc4d4ffd629b9052e85.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/monitorix/PKGBUILD')
-rw-r--r--abs/extra/monitorix/PKGBUILD45
1 files changed, 17 insertions, 28 deletions
diff --git a/abs/extra/monitorix/PKGBUILD b/abs/extra/monitorix/PKGBUILD
index e73fcd1..d2dceec 100644
--- a/abs/extra/monitorix/PKGBUILD
+++ b/abs/extra/monitorix/PKGBUILD
@@ -1,22 +1,22 @@
-# Maintainer: graysky <da_audiophile yahoo>
+# Contributor: graysky <graysky AT archlinux dot us>
+# Contributor: res <andres87p gmail>
pkgname=monitorix
-pkgver=1.4.2
-pkgrel=8
+pkgver=1.5.2
+pkgrel=1
pkgdesc='A lightweight system monitoring tool that uses rrd databases.'
-arch=(i686)
+arch=(any)
url=http://www.$pkgname.org/
license=(GPL)
-depends=(dcron rrdtool lighttpd )
+depends=('rrdtool' 'perl-libwww')
optdepends=('lm_sensors: enable support for system temp monitoring'
-'hddtemp: enable support for hdd temp monitoring')
+'hddtemp: enable support for hdd temp monitoring'
+'metamail: enable support for reports via system mail')
backup=(etc/$pkgname.conf)
source=($url$pkgname-$pkgver.tar.gz
monitorix.rc.d)
-md5sums=('6db1bdbeeb0d128622590dfecb9694e4'
-'34e7cb2d78bb4e3ece4aeb4ed26a0d43')
-install=('monitorix.install')
+install=('readme.install')
build() {
cd $pkgname-$pkgver
@@ -24,22 +24,10 @@ build() {
install -D $pkgname.pl $pkgdir/usr/sbin/$pkgname.pl
install -D ../$pkgname.rc.d $pkgdir/etc/rc.d/$pkgname
-# use LinHES defaults
+# use Arch defaults
sed -e '/^our $OSTYPE/ s,RHFC,Arch,' \
- -e '/^our $TITLE/ s,FIBRANET NSP\, SL,LinHES,' \
- -e '/^our @HDDTEMP_LIST/ s,hda,sda,' \
- -e '/^our $ENABLE_CROND_MAIL/ s,Y,N,' \
- -e '/^our $ENABLE_SERVU/ s,Y,N,' \
- -e '/^our $ENABLE_PORT/ s,Y,N,' \
- -e '/^our $ENABLE_USER/ s,Y,N,' \
- -e '/^our $ENABLE_INT/ s,Y,N,' \
- -e '/^our @HDDTEMP_LIST/ s,hda,sda,' \
- -e '/^our @MNT_LIST/ s,boot,myth,' \
- -e '/^\s*"Linux-Arch"/ s,/var/log/httpd/access.log,/var/log/httpd/access_log,' \
- -e '/^\s*"Linux-Arch"/ s,/var/log/secure,/var/log/auth.log,' \
- -e '/^\s*"Linux-Arch"/ s,/srv/http,/data/srv/httpd/htdocs,' < $pkgname.conf \
- > $pkgdir/etc/$pkgname.conf
-
+ -e '/^our @HDDTEMP_LIST/ s,hda,sda,' < $pkgname.conf \
+ > $pkgdir/etc/$pkgname.conf
mkdir -p $pkgdir/var/lib/$pkgname/usage
cp -r reports $pkgdir/var/lib/$pkgname
@@ -47,12 +35,13 @@ build() {
cp Changes $pkgname-apache.conf $pkgname-alert.sh README README.nginx TODO \
$pkgdir/usr/share/doc/$pkgname
- install -dm777 $pkgdir/data/srv/httpd/htdocs/$pkgname/imgs
- cp {logo_bot,logo_top,${pkgname}ico}.png $pkgdir/data/srv/httpd/htdocs/$pkgname
+ install -dm777 $pkgdir/srv/http/$pkgname/imgs
+ cp {logo_bot,logo_top,${pkgname}ico}.png $pkgdir/srv/http/$pkgname
- install -D $pkgname.cgi $pkgdir/data/srv/httpd/htdocs/cgi-bin/$pkgname.cgi
+ install -D $pkgname.cgi $pkgdir/srv/http/cgi-bin/$pkgname.cgi
gzip -9 man/man5/$pkgname.conf.5
install -Dm644 man/man5/$pkgname.conf.5.gz $pkgdir/usr/share/man/man5/$pkgname.conf.5.gz
}
-
+sha256sums=('3d025d097fe8dd458501b8cf3345b80b1b66625ae257e21452b95d1596ec5b6d'
+ 'f9ba4e09f8e583808bc9fa5476ddac067182799512e103ea40565b7da47dbab6')