summaryrefslogtreecommitdiffstats
path: root/abs/extra/mpg123/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-10 23:13:08 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-10 23:13:08 (GMT)
commit88c1b84963b442a1d39d8193ce72d17e297f006f (patch)
tree707179173751bff29a018a403dbed4923db47985 /abs/extra/mpg123/PKGBUILD
parentbf347ccc26e6d65950cea72b1990dbf8c9fe98c1 (diff)
parent7921961814dea89fbf846d06095afd207c8dfd23 (diff)
downloadlinhes_pkgbuild-88c1b84963b442a1d39d8193ce72d17e297f006f.zip
linhes_pkgbuild-88c1b84963b442a1d39d8193ce72d17e297f006f.tar.gz
linhes_pkgbuild-88c1b84963b442a1d39d8193ce72d17e297f006f.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/mpg123/PKGBUILD')
-rw-r--r--abs/extra/mpg123/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/extra/mpg123/PKGBUILD b/abs/extra/mpg123/PKGBUILD
new file mode 100644
index 0000000..5b1b335
--- /dev/null
+++ b/abs/extra/mpg123/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 85300 2010-07-11 18:52:51Z eric $
+# Maintainer: Hugo Doria <hugo@archlinux.org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+
+pkgname=mpg123
+pkgver=1.12.3
+pkgrel=1
+pkgdesc="A console based real time MPEG Audio Player for Layer 1, 2 and 3"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/mpg123"
+license=('GPL2' 'LGPL2.1')
+depends=('glibc' 'libtool' 'alsa-lib')
+makedepends=('esound' 'sdl')
+optdepends=('esound: for additional audio support' 'sdl: for additional audio support')
+conflicts=('mpg321')
+provides=('mpg321')
+replaces=('mpg321')
+options=('libtool')
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('c1568be2d1715786bd6b1a89ec6fa7ef')
+sha1sums=('5e92d3c918f6095264089f711a9f38a5d2168b31')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --with-audio="alsa esd sdl"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+