summaryrefslogtreecommitdiffstats
path: root/abs/extra/mythexport
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-03 17:59:45 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-03 17:59:45 (GMT)
commit4be23d4482a7aec8820be8fa373bc8de5a0272b5 (patch)
tree453c78e84078cb6cfa3da1daa4906050aedb68a2 /abs/extra/mythexport
parent306d9e4bfa29faaa561d54df14a0533d034f9773 (diff)
downloadlinhes_pkgbuild-4be23d4482a7aec8820be8fa373bc8de5a0272b5.zip
linhes_pkgbuild-4be23d4482a7aec8820be8fa373bc8de5a0272b5.tar.gz
linhes_pkgbuild-4be23d4482a7aec8820be8fa373bc8de5a0272b5.tar.bz2
mythweb, mythexport,zoneminder, web_auth: convert packages to use gen_light_include.conf
refs #864 closes #864
Diffstat (limited to 'abs/extra/mythexport')
-rw-r--r--abs/extra/mythexport/PKGBUILD9
-rw-r--r--abs/extra/mythexport/mythexport.install30
-rw-r--r--abs/extra/mythexport/mythexport_gen_light.conf1
3 files changed, 11 insertions, 29 deletions
diff --git a/abs/extra/mythexport/PKGBUILD b/abs/extra/mythexport/PKGBUILD
index 1a51bd2..9a973e5 100644
--- a/abs/extra/mythexport/PKGBUILD
+++ b/abs/extra/mythexport/PKGBUILD
@@ -13,8 +13,9 @@ depends=('atomicparsley' 'perl-config-simple' 'perl-net-upnp' 'perl-xml-rss'
optdepends=('lighttpd: For web based interaction')
url="http://www.ubuntuupdates.org/mythexport"
source=(https://launchpad.net/ubuntu/precise/+source/${pkgname}/${pkgver}-0ubuntu2/+files/${pkgname}_${pkgver}.orig.tar.gz
- mythexport.lighttpd.include
- linhes.diff)
+ mythexport.lighttpd.include mythexport_gen_light.conf
+ linhes.diff
+ )
install=mythexport.install
build() {
@@ -32,6 +33,9 @@ package() {
# Install lighttpd include file
install -D -m644 ${srcdir}/mythexport.lighttpd.include ${pkgdir}/etc/mythexport/mythexport.lighttpd.include
+ #gen_light_conf
+ install -D -m0744 ${srcdir}/mythexport_gen_light.conf ${pkgdir}/etc/gen_light_conf.d/mythexport.conf
+
# Compress man pages
gzip -9 *.1
install -D -m644 mythexport.1.gz ${pkgdir}/usr/share/man/man1/mythexport.1.gz || return 1
@@ -43,4 +47,5 @@ package() {
}
md5sums=('a780c00536a4680ce7d79057658971c8'
'b08404255abcc99a35e9c1ab8e0dec57'
+ 'e6f84aa222eddf803a81d1b92a315d06'
'e32369bb2fde6352798e3522d67527b2')
diff --git a/abs/extra/mythexport/mythexport.install b/abs/extra/mythexport/mythexport.install
index a599f2d..2718715 100644
--- a/abs/extra/mythexport/mythexport.install
+++ b/abs/extra/mythexport/mythexport.install
@@ -17,15 +17,7 @@ post_install() {
chown mythtv:mythtv /var/run/mythtv
chown -R mythtv:mythtv /etc/mythtv
- COUNT=`grep -c "include \"/etc/mythexport/mythexport.lighttpd.include\"" /etc/lighttpd/conf.include`
-
- if [ $COUNT == 0 ] ; then
- echo "==> Adding mythexport.lighttpd.include to conf.include"
- echo "include \"/etc/mythexport/mythexport.lighttpd.include\"" >> \
- /etc/lighttpd/conf.include
- fi
-
- echo ""
+ gen_light_include.py
echo "==> Forcing a re-read of lighttpd's configuration file."
echo ""
/sbin/sv hup /service/lighttpd
@@ -45,15 +37,7 @@ post_install() {
}
post_upgrade() {
-
- COUNT=`grep -c "include \"/etc/mythexport/mythexport.lighttpd.include\"" /etc/lighttpd/conf.include`
-
- if [ $COUNT == 0 ] ; then
- echo "==> Adding mythexport.lighttpd.include to conf.include"
- echo "include \"/etc/mythexport/mythexport.lighttpd.include\"" >> \
- /etc/lighttpd/conf.include
- fi
-
+ gen_light_include.py
echo ""
echo "==> Forcing a re-read of lighttpd's configuration file."
echo ""
@@ -68,15 +52,7 @@ pre_remove() {
}
post_remove() {
-
- COUNT=`grep -c "include \"/etc/mythexport/mythexport.lighttpd.include\"" /etc/lighttpd/conf.include`
-
- if [ $COUNT -gt 0 ] ; then
- echo "==> Removing mythexport.lighttpd.include from conf.include"
- sed -e 's#include \"/etc/mythexport/mythexport.lighttpd.include\"##' -i \
- /etc/lighttpd/conf.include
- fi
-
+ gen_light_include.py
echo ""
echo "==> Forcing re-read of lighttpd's configuration file."
echo ""
diff --git a/abs/extra/mythexport/mythexport_gen_light.conf b/abs/extra/mythexport/mythexport_gen_light.conf
new file mode 100644
index 0000000..f495657
--- /dev/null
+++ b/abs/extra/mythexport/mythexport_gen_light.conf
@@ -0,0 +1 @@
+include "/etc/mythexport/mythexport.lighttpd.include"