summaryrefslogtreecommitdiffstats
path: root/abs/extra/mythexport
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-12-18 09:50:29 (GMT)
committerCecil <knoppmyth@gmail.com>2011-12-18 09:50:29 (GMT)
commitc1f1911c0993407590afcb2af8662e8e8099fca1 (patch)
tree9b9313d40d93b6e200ba26541cbdd5609a4ded2c /abs/extra/mythexport
parentb0e1f2b031c139e76d26743aaf3de7450a383280 (diff)
downloadlinhes_pkgbuild-c1f1911c0993407590afcb2af8662e8e8099fca1.zip
linhes_pkgbuild-c1f1911c0993407590afcb2af8662e8e8099fca1.tar.gz
linhes_pkgbuild-c1f1911c0993407590afcb2af8662e8e8099fca1.tar.bz2
mythexport:resolves 767. Should now work out the box w/ LinHES! Added multiple profiles for various devices.
Diffstat (limited to 'abs/extra/mythexport')
-rw-r--r--abs/extra/mythexport/PKGBUILD10
-rw-r--r--abs/extra/mythexport/linhes.diff595
-rw-r--r--abs/extra/mythexport/mythexport.install22
3 files changed, 621 insertions, 6 deletions
diff --git a/abs/extra/mythexport/PKGBUILD b/abs/extra/mythexport/PKGBUILD
index d919f61..73a18cd 100644
--- a/abs/extra/mythexport/PKGBUILD
+++ b/abs/extra/mythexport/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mythexport
pkgver=2.2.3
-pkgrel=4
+pkgrel=6
pkgdesc="Export MythTV recording to portable media players"
arch=('i686' 'x86_64')
license=('GPL3')
@@ -12,7 +12,8 @@ depends=('atomicparsley' 'perl-config-simple' 'perl-net-upnp' 'perl-xml-rss'
optdepends=('lighttpd: For web based interaction')
url="http://www.ubuntuupdates.org/mythexport"
source=(https://launchpad.net/ubuntu/precise/+source/${pkgname}/${pkgver}-0ubuntu2/+files/${pkgname}_${pkgver}.orig.tar.gz
- mythexport.lighttpd.include)
+ mythexport.lighttpd.include
+ linhes.diff)
install=mythexport.install
build() {
@@ -23,6 +24,8 @@ build() {
package() {
cd ${srcdir}/${pkgname}-${pkgver}
+ patch -p1 < ../linhes.diff || return 1
+ cp -a ./etc ${pkgdir}/ || return 1
cp -a ./usr ${pkgdir}/ || return 1
# Install lighttpd include file
@@ -38,4 +41,5 @@ package() {
}
md5sums=('a780c00536a4680ce7d79057658971c8'
- 'b08404255abcc99a35e9c1ab8e0dec57')
+ 'b08404255abcc99a35e9c1ab8e0dec57'
+ 'e32369bb2fde6352798e3522d67527b2')
diff --git a/abs/extra/mythexport/linhes.diff b/abs/extra/mythexport/linhes.diff
new file mode 100644
index 0000000..30bd0ba
--- /dev/null
+++ b/abs/extra/mythexport/linhes.diff
@@ -0,0 +1,595 @@
+diff -ruaN mythexport-2.2.3.orig//etc/apache2/sites-available/mythexport.conf mythexport-2.2.3//etc/apache2/sites-available/mythexport.conf
+--- mythexport-2.2.3.orig//etc/apache2/sites-available/mythexport.conf 2011-04-26 06:04:09.000000000 +0000
++++ mythexport-2.2.3//etc/apache2/sites-available/mythexport.conf 1970-01-01 00:00:00.000000000 +0000
+@@ -1,19 +0,0 @@
+-<Directory "/var/www/mythexport">
+- AllowOverride None
+- Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
+- Order allow,deny
+- Allow from all
+- <Files *.cgi>
+- SetHandler cgi-script
+- Options +ExecCGI
+- </Files>
+-
+- DirectoryIndex file.cgi
+- # Turned off as we are now hosting up more than just a RSS feed
+- #RewriteEngine on
+- #RewriteRule ^([A-Za-z0-9-_]+)/?$ mythexportRSS.cgi?podcastName=$1 [L]
+-</Directory>
+-<Directory "/var/www/.mythtv">
+- AllowOverride None
+- Deny from all
+-</Directory>
+diff -ruaN mythexport-2.2.3.orig//etc/mythtv/mythexport/mythexport.cfg mythexport-2.2.3//etc/mythtv/mythexport/mythexport.cfg
+--- mythexport-2.2.3.orig//etc/mythtv/mythexport/mythexport.cfg 1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3//etc/mythtv/mythexport/mythexport.cfg 2011-12-18 09:27:11.000000000 +0000
+@@ -0,0 +1,2 @@
++dir=/myth/mythexport
++
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/Android.pm mythexport-2.2.3//usr/share/mythexport/configs/Android.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/Android.pm 1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythexport/configs/Android.pm 2011-12-18 09:27:11.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl
++
++package Android;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "Handbrake MPEG4 output for Android devices.";
++my $devices = "Android";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++ my $class = shift;
++ my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++ bless $self, $class;
++ return $self;
++}
++
++sub export{
++ my( $self ) = @_;
++
++ system("HandBrakeCLI -i \'$self->{_inputFile}\' -o '$self->{_outputFile}$self->{_extension}\' -f mp4 -w 480 -l 320 --deinterlace=\"slow\" -e x264 -x cabac=0:deblock=1,0:analyse=0x1,0x111:bitrate=416:psy_rd=1.0,0.0:chroma_me=1:chroma_qp_offset=-2:threads=3:nr=0:keyint=250:keyint_min=25:scenecut=40:bitrate=416:ratetol=1.0:qcomp=0.60:qpmin=10:qpmax=51:qpstep=4:cplxblur=20.0:qblur=0.5 -a 1 -E faac -B 96 -R 44.1 -6 stereo -D 1 -v -2 -T");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/AppleTV.pm mythexport-2.2.3//usr/share/mythexport/configs/AppleTV.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/AppleTV.pm 1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythexport/configs/AppleTV.pm 2011-12-18 09:27:11.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl
++
++package AppleTV;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's settings for the AppleTV and 2009's iPhone and iPod Touch lineup. Provides a good balance between quality and file size, and pushes the devices to their limits. Includes Dolby Digital 5.1 AC3 sound for the AppleTV.";
++my $devices = "AppleTV";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++ my $class = shift;
++ my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++ bless $self, $class;
++ return $self;
++}
++
++sub export{
++ my( $self ) = @_;
++
++ system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"AppleTV\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/AppleTV2.pm mythexport-2.2.3//usr/share/mythexport/configs/AppleTV2.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/AppleTV2.pm 1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythexport/configs/AppleTV2.pm 2011-12-18 09:27:11.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl
++
++package AppleTV2;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's preset for the Apple TV (2nd gen) is optimized for viewing on its 1280x720 display.";
++my $devices = "AppleTV2";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++ my $class = shift;
++ my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++ bless $self, $class;
++ return $self;
++}
++
++sub export{
++ my( $self ) = @_;
++
++ system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"AppleTV 2\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/Classic.pm mythexport-2.2.3//usr/share/mythexport/configs/Classic.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/Classic.pm 1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythexport/configs/Classic.pm 2011-12-18 09:27:11.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl
++
++package Classic;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's traditional, faster, lower-quality settings.";
++my $devices = "";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++ my $class = shift;
++ my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++ bless $self, $class;
++ return $self;
++}
++
++sub export{
++ my( $self ) = @_;
++
++ system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"Classic\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/HighProfile.pm mythexport-2.2.3//usr/share/mythexport/configs/HighProfile.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/HighProfile.pm 1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythexport/configs/HighProfile.pm 2011-12-18 09:27:11.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl
++
++package HighProfile;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's general-purpose preset for High Profile H.264 video, with all the bells and whistles.";
++my $devices = "";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++ my $class = shift;
++ my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++ bless $self, $class;
++ return $self;
++}
++
++sub export{
++ my( $self ) = @_;
++
++ system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"High Profile\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/NIT.pm mythexport-2.2.3//usr/share/mythexport/configs/NIT.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/NIT.pm 1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythexport/configs/NIT.pm 2011-12-18 09:27:11.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl
++
++package NIT;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "High Quality export for Nokia Internet Tablets (used BeyondPod).";
++my $devices = "N770, N800 and N900";
++my $notes = "Tested fine on Andriod phones and tablets.";
++my $version = "1.0";
++
++sub new{
++ my $class = shift;
++ my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++ bless $self, $class;
++ return $self;
++}
++
++sub export{
++ my( $self ) = @_;
++
++ system("/usr/bin/tablet-encode -q -p mplayer \'$self->{_inputFile}\' \'$self->{_outputFile}$self->{_extension}\'");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/NIT900.pm mythexport-2.2.3//usr/share/mythexport/configs/NIT900.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/NIT900.pm 1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythexport/configs/NIT900.pm 2011-12-18 09:27:11.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl
++
++package NIT900;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "High Quality export for N900.";
++my $devices = "N900";
++my $notes = "Tested fine on Andriod phones and tablets (used BeyondPod).";
++my $version = "1.0";
++
++sub new{
++ my $class = shift;
++ my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++ bless $self, $class;
++ return $self;
++}
++
++sub export{
++ my( $self ) = @_;
++
++ system("/usr/bin/tablet-encode -q -p n900 \'$self->{_inputFile}\' \'$self->{_outputFile}$self->{_extension}\'");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/Normal.pm mythexport-2.2.3//usr/share/mythexport/configs/Normal.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/Normal.pm 1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythexport/configs/Normal.pm 2011-12-18 09:27:11.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl
++
++package Normal;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's normal, default settings.";
++my $devices = "";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++ my $class = shift;
++ my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++ bless $self, $class;
++ return $self;
++}
++
++sub export{
++ my( $self ) = @_;
++
++ system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"Normal\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/PortableH264HighRes.pm mythexport-2.2.3//usr/share/mythexport/configs/PortableH264HighRes.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/PortableH264HighRes.pm 2011-04-26 06:04:09.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythexport/configs/PortableH264HighRes.pm 1970-01-01 00:00:00.000000000 +0000
+@@ -1,28 +0,0 @@
+-#!/usr/bin/perl
+-
+-package PortableH264HighRes;
+-
+-use ExportBase;
+-
+-our @ISA = qw(ExportBase);
+-
+-my $description = "High Resolution (800x400) Portable H264 Settings.";
+-my $devices = "High Resolution Android Devices (example Droid, Evo, N1), iPod Touch, iPhone, iPad";
+-my $notes = "Requires AAC, <a href=\"https://help.ubuntu.com/community/Medibuntu\">activate Medibuntu</a>";
+-my $version = "1.0";
+-
+-sub new{
+- my $class = shift;
+- my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
+- bless $self, $class;
+- return $self;
+-}
+-
+-sub export{
+- my( $self ) = @_;
+-
+- system("ffmpeg -i \'$self->{_inputFile}\' -y -pass 1 -an -vcodec libx264 -vpre slowfirstpass -vpre ipod640 -b 1500kb -bt 1000kb -threads 0 -s 800x480 -aspect 16:9 -f ipod \'$self->{_outputFile}$self->{_extension}\' && ffmpeg -i \'$self->{_inputFile}\' -y -pass 2 -vcodec libx264 -vpre hq -vpre ipod640 -b 1500kb -bt 1000kb -threads 0 -s 800x480 -acodec libfaac -ab 192kb -ac 2 -aspect 16:9 -f ipod \'$self->{_outputFile}$self->{_extension}\'");
+-
+-}
+-
+-1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/PortableH264LowRes.pm mythexport-2.2.3//usr/share/mythexport/configs/PortableH264LowRes.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/PortableH264LowRes.pm 2011-04-26 06:04:09.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythexport/configs/PortableH264LowRes.pm 1970-01-01 00:00:00.000000000 +0000
+@@ -1,28 +0,0 @@
+-#!/usr/bin/perl
+-
+-package PortableH264LowRes;
+-
+-use ExportBase;
+-
+-our @ISA = qw(ExportBase);
+-
+-my $description = "Low Resolution (480x320) Portable H264 Settings.";
+-my $devices = "Low Resolution Android Devices (example HTC Hero), iPod Classic, iPod Nano";
+-my $notes = "Requires AAC, <a href=\"https://help.ubuntu.com/community/Medibuntu\">activate Medibuntu</a>";
+-my $version = "1.0";
+-
+-sub new{
+- my $class = shift;
+- my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
+- bless $self, $class;
+- return $self;
+-}
+-
+-sub export{
+- my( $self ) = @_;
+-
+- system("ffmpeg -i \'$self->{_inputFile}\' -y -pass 1 -an -vcodec libx264 -vpre slowfirstpass -vpre ipod320 -b 1500kb -bt 1000kb -threads 0 -s 480x320 -aspect 16:9 -f ipod \'$self->{_outputFile}$self->{_extension}\' && ffmpeg -i \'$self->{_inputFile}\' -y -pass 2 -vcodec libx264 -vpre hq -vpre ipod320 -b 1500kb -bt 1000kb -threads 0 -s 480x320 -acodec libfaac -ab 192kb -ac 2 -aspect 16:9 -f ipod \'$self->{_outputFile}$self->{_extension}\'");
+-
+-}
+-
+-1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/Universal.pm mythexport-2.2.3//usr/share/mythexport/configs/Universal.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/Universal.pm 1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythexport/configs/Universal.pm 2011-12-18 09:27:11.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl
++
++package Universal;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's universally compatible, full resolution settings for all current Apple devices";
++my $devices = "iPod (6G and up), iPhone, AppleTV, and Macs.";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++ my $class = shift;
++ my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++ bless $self, $class;
++ return $self;
++}
++
++sub export{
++ my( $self ) = @_;
++
++ system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"Universal\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/iPad.pm mythexport-2.2.3//usr/share/mythexport/configs/iPad.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/iPad.pm 1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythexport/configs/iPad.pm 2011-12-18 09:27:11.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl
++
++package iPad;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's preset for the iPad is optimized for viewing on its 1024x768 display";
++my $devices = "iPad";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++ my $class = shift;
++ my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++ bless $self, $class;
++ return $self;
++}
++
++sub export{
++ my( $self ) = @_;
++
++ system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"iPad\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/iPhone.pm mythexport-2.2.3//usr/share/mythexport/configs/iPhone.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/iPhone.pm 1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythexport/configs/iPhone.pm 2011-12-18 09:27:11.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl
++
++package iPhone;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's settings for all iPhones and iPod Touches going back to the original iPhone 2G.";
++my $devices = "iPhone and iPod Touch";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++ my $class = shift;
++ my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++ bless $self, $class;
++ return $self;
++}
++
++sub export{
++ my( $self ) = @_;
++
++ system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"iPhone & iPod Touch\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/iPhone4.pm mythexport-2.2.3//usr/share/mythexport/configs/iPhone4.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/iPhone4.pm 1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythexport/configs/iPhone4.pm 2011-12-18 09:27:11.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl
++
++package iPhone4;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's preset for the iPhone 4 is optimized for viewing on its 960x480 display.";
++my $devices = "iPhone 4";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++ my $class = shift;
++ my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++ bless $self, $class;
++ return $self;
++}
++
++sub export{
++ my( $self ) = @_;
++
++ system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"iPhone 4\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/iPod.pm mythexport-2.2.3//usr/share/mythexport/configs/iPod.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/iPod.pm 1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythexport/configs/iPod.pm 2011-12-18 09:27:11.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl
++
++package iPod;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "HandBrake's low resolution settings, optimized for great playback on the iPod screen, with smaller file size. ";
++my $devices = "iPod (5G and up)";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++ my $class = shift;
++ my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++ bless $self, $class;
++ return $self;
++}
++
++sub export{
++ my( $self ) = @_;
++
++ system("HandBrakeCLI -i \'$self->{_inputFile}\' -o \'$self->{_outputFile}$self->{_extension}\' --preset=\"iPod\"");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythexport/configs/x264.pm mythexport-2.2.3//usr/share/mythexport/configs/x264.pm
+--- mythexport-2.2.3.orig//usr/share/mythexport/configs/x264.pm 1970-01-01 00:00:00.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythexport/configs/x264.pm 2011-12-18 09:27:11.000000000 +0000
+@@ -0,0 +1,28 @@
++#!/usr/bin/perl
++
++package x264;
++
++use ExportBase;
++
++our @ISA = qw(ExportBase);
++
++my $description = "Uses Handbrake to transcode recording to x264.";
++my $devices = "";
++my $notes = "";
++my $version = "1.0";
++
++sub new{
++ my $class = shift;
++ my $self = $class->SUPER::new(shift, shift, $description, $devices, $notes, $version);
++ bless $self, $class;
++ return $self;
++}
++
++sub export{
++ my( $self ) = @_;
++
++ system("HandBrakeCLI -i \'$self->{_inputFile}\' -o '$self->{_outputFile}$self->{_extension}\' -f mp4 -w 480 -l 320 --deinterlace=\"slow\" -e x264 -x cabac=0:deblock=1,0:analyse=0x1,0x111:bitrate=416:psy_rd=1.0,0.0:chroma_me=1:chroma_qp_offset=-2:threads=3:nr=0:keyint=250:keyint_min=25:scenecut=40:bitrate=416:ratetol=1.0:qcomp=0.60:qpmin=10:qpmax=51:qpstep=4:cplxblur=20.0:qblur=0.5 -a 1 -E faac -B 96 -R 44.1 -6 stereo -D 1 -v -2 -T");
++
++}
++
++1;
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythtv/mythexport/images/powered_apache_80x15_2.png mythexport-2.2.3//usr/share/mythtv/mythexport/images/powered_apache_80x15_2.png
+--- mythexport-2.2.3.orig//usr/share/mythtv/mythexport/images/powered_apache_80x15_2.png 2011-04-26 06:04:09.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythtv/mythexport/images/powered_apache_80x15_2.png 1970-01-01 00:00:00.000000000 +0000
+@@ -1,5 +0,0 @@
+-PNG
+-
+-
+-* ?7 YG ))
+-
+\ No newline at end of file
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythtv/mythexport/images/powered_mysql_80x15_2.png mythexport-2.2.3//usr/share/mythtv/mythexport/images/powered_mysql_80x15_2.png
+--- mythexport-2.2.3.orig//usr/share/mythtv/mythexport/images/powered_mysql_80x15_2.png 2011-04-26 06:04:09.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythtv/mythexport/images/powered_mysql_80x15_2.png 1970-01-01 00:00:00.000000000 +0000
+@@ -1,3 +0,0 @@
+-PNG
+-
+-
+\ No newline at end of file
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythtv/mythexport/images/powered_ubuntu_80x15_2.png mythexport-2.2.3//usr/share/mythtv/mythexport/images/powered_ubuntu_80x15_2.png
+--- mythexport-2.2.3.orig//usr/share/mythtv/mythexport/images/powered_ubuntu_80x15_2.png 2011-04-26 06:04:09.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythtv/mythexport/images/powered_ubuntu_80x15_2.png 1970-01-01 00:00:00.000000000 +0000
+@@ -1,4 +0,0 @@
+-PNG
+-
+-
+-42<;ĉ]ͯdOa0cd?D%'0;;S.AS<ۗ|_+DݜEڔJ3d
+\ No newline at end of file
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythtv/mythexport/player.cgi mythexport-2.2.3//usr/share/mythtv/mythexport/player.cgi
+--- mythexport-2.2.3.orig//usr/share/mythtv/mythexport/player.cgi 2011-04-26 06:04:09.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythtv/mythexport/player.cgi 2011-12-18 09:27:34.000000000 +0000
+@@ -29,7 +29,7 @@
+ my $query_handle = $connect->prepare($query);
+ $query_handle->execute($id) || die "Unable to query mythexport table";
+
+- $content = "<p>This page is a work in progress, it may work for your Anroid device or iPhone.<br />";
++ $content = "<p>This page is a work in progress, it may work for your Android device or iPhone.<br />";
+
+ while ( my $file = $query_handle->fetchrow_array() ) {
+ $content .= "<video width=\"480\" height=\"320\" autobuffer controls onClick=\"this.play();\">
+diff -ruaN mythexport-2.2.3.orig//usr/share/mythtv/mythexport/template/template.tmpl mythexport-2.2.3//usr/share/mythtv/mythexport/template/template.tmpl
+--- mythexport-2.2.3.orig//usr/share/mythtv/mythexport/template/template.tmpl 2011-04-26 06:04:09.000000000 +0000
++++ mythexport-2.2.3//usr/share/mythtv/mythexport/template/template.tmpl 2011-12-18 09:27:11.000000000 +0000
+@@ -32,11 +32,5 @@
+ <div id="content">
+ <TMPL_VAR NAME=CONTENT>
+ <div class="clear">&nbsp;</div>
+- </div>
+- <div id="buttons">
+- <a title="Powered By Ubuntu" href="http://www.ubuntu.com"><img src="images/powered_ubuntu_80x15_2.png" alt="Powered By Ubuntu" width="80" height="15" /></a>
+- <a title="Powered By Apache" href="http://www.apache.org/"><img src="images/powered_apache_80x15_2.png" alt="Powered By Apache" width="80" height="15" /></a>
+- <a title="Powered By MySQL" href="http://www.mysql.com"><img src="images/powered_mysql_80x15_2.png" alt="Powered By MySQL" width="80" height="15" /></a>
+- </div>
+ </body>
+ </html>
diff --git a/abs/extra/mythexport/mythexport.install b/abs/extra/mythexport/mythexport.install
index a6a2085..361f1e5 100644
--- a/abs/extra/mythexport/mythexport.install
+++ b/abs/extra/mythexport/mythexport.install
@@ -1,8 +1,22 @@
# arg 1: the new package version
post_install() {
+ if [ ! -d /myth/mythexport ];then
+ mkdir /myth/mythexport
+ fi
+ if [ ! -d /var/run/mythtv ];then
+ mkdir /var/run/mythtv
+ fi
+ if [ ! -d /srv/http/.mythtv ];then
+ mkdir /srv/http/.mythtv
+ fi
+ chown -R mythtv:mythtv /myth/mythexport
+
mysql -u root mythconverg < /usr/share/mythtv/mythexport.sql
ln -s /usr/share/mythtv/mythexport /data/srv/httpd/htdocs/
- ln -s /myth/archive /usr/share/mythtv/mythexport/video
+ ln -s /myth/mythexport /usr/share/mythtv/mythexport/video
+ ln -s /home/mythtv/.mythtv/config.xml /srv/http/.mythtv
+ chown mythtv:mythtv /var/run/mythtv
+ chown -R mythtv:mythtv /etc/mythtv
COUNT=`grep -c "include \"/etc/mythexport/mythexport.lighttpd.include\"" /etc/lighttpd/conf.include`
@@ -18,9 +32,11 @@ post_install() {
/sbin/sv hup /service/lighttpd
echo ""
- echo "==> Add the mythexport service to start the mythexport daemon"
- echo "==> $ sudo add_service.sh mythexport"
+ echo "==> Adding the mythexport service to start the mythexport daemon"
+ add_service.sh mythexport
echo ""
+ echo "==> Starting MythExport..."
+ /sbin/sv start mythexport
echo ""
echo "==> For move information on setup and configuration:"