summaryrefslogtreecommitdiffstats
path: root/abs/extra/mythexpress
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-04-28 15:39:35 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-04-28 15:39:35 (GMT)
commit3440ea7444495de8f38aad0d19d007cc5d934473 (patch)
tree04c9d605d15303dd2cea3e85a9180fc75bc23ca9 /abs/extra/mythexpress
parent65bb91f1fbd6e4237dbeaed44790a35afbcea2bf (diff)
downloadlinhes_pkgbuild-3440ea7444495de8f38aad0d19d007cc5d934473.zip
linhes_pkgbuild-3440ea7444495de8f38aad0d19d007cc5d934473.tar.gz
linhes_pkgbuild-3440ea7444495de8f38aad0d19d007cc5d934473.tar.bz2
mythexpress: update to latest
add mythprotocol.js patch to work with .28
Diffstat (limited to 'abs/extra/mythexpress')
-rwxr-xr-xabs/extra/mythexpress/PKGBUILD15
-rwxr-xr-xabs/extra/mythexpress/mythexpress.html4
-rw-r--r--abs/extra/mythexpress/mythprotocol.js.patch12
3 files changed, 23 insertions, 8 deletions
diff --git a/abs/extra/mythexpress/PKGBUILD b/abs/extra/mythexpress/PKGBUILD
index d6ac582..229e28a 100755
--- a/abs/extra/mythexpress/PKGBUILD
+++ b/abs/extra/mythexpress/PKGBUILD
@@ -1,14 +1,14 @@
pkgname=mythexpress
-pkgver=20160128
+pkgver=20160427
pkgrel=1
pkgdesc="MythExpress is a browser-based interface to MythTV HTTP streaming capability"
arch=('i686' 'x86_64')
url="https://github.com/MythTV-Clients/MythExpress"
license=('GPL3')
-depends=('nodejs' 'avahi' )
+depends=('nodejs' 'avahi')
makedepends=('git')
-install=('mythexpress.install')
-source=('mythexpress.html' )
+install=mythexpress.install
+source=('mythexpress.html' 'mythprotocol.js.patch')
_gitroot="https://github.com/MythTV-Clients/MythExpress.git"
_gitname=MythExpress
@@ -32,6 +32,8 @@ build() {
fi
cp -rf "${_gitname}" "${_gitname}-build"
+ patch -Np1 -i ${srcdir}/mythprotocol.js.patch
+
cd "${srcdir}/${_gitname}-build"
npm install || exit 1
@@ -41,7 +43,8 @@ package() {
cd "${srcdir}"
mkdir -p $pkgdir/usr/$pkgname
rsync -arvp --exclude .git ${_gitname}-build/ $pkgdir/usr/${pkgname}
- cd $startdir/src
+ cd "${srcdir}"
install -m755 -D mythexpress.html $pkgdir/data/srv/httpd/htdocs/mythexpress.html
}
-md5sums=('93b0d936c5c7838e1c0367f2d5286b3b')
+md5sums=('568ee396fc2af9fd7cc3433fce7a3a87'
+ 'd5d20eb47e9dffb238e60173810bd24b')
diff --git a/abs/extra/mythexpress/mythexpress.html b/abs/extra/mythexpress/mythexpress.html
index d9dd9a3..8302e5a 100755
--- a/abs/extra/mythexpress/mythexpress.html
+++ b/abs/extra/mythexpress/mythexpress.html
@@ -10,7 +10,7 @@ function r()
function express()
{
current_hostname=parent.location.hostname
- top.frames["content"].location.href = ( "http://" + current_hostname + ":6565" ) ;
+ window.location.href = ( "http://" + current_hostname + ":6565" ) ;
}
@@ -27,4 +27,4 @@ function remyth()
<body onload="JavaScript:express();">
</body>
-</html> \ No newline at end of file
+</html>
diff --git a/abs/extra/mythexpress/mythprotocol.js.patch b/abs/extra/mythexpress/mythprotocol.js.patch
new file mode 100644
index 0000000..ebfe808
--- /dev/null
+++ b/abs/extra/mythexpress/mythprotocol.js.patch
@@ -0,0 +1,12 @@
+--- src/MythExpress-build/mythtv/mythprotocol.js.orig 2016-04-27 22:00:34.538603111 +0000
++++ src/MythExpress-build/mythtv/mythprotocol.js 2016-04-28 15:20:43.518464024 +0000
+@@ -53,7 +53,8 @@
+ "85" : "BluePool",
+ "86" : "(ノಠ益ಠ)ノ彡┻━┻",
+ "87" : "(ノಠ益ಠ)ノ彡┻━┻_No_entiendo!)",
+- "Latest" : "87"
++ "88" : "XmasGift",
++ "Latest" : "88"
+ };
+
+ var reconnectInterval = 6;