summaryrefslogtreecommitdiffstats
path: root/abs/extra/mythexpress
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-01-15 18:02:19 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-01-15 18:02:19 (GMT)
commit38d2158355d4ebddf3bcf10a488fdf85c4f57d90 (patch)
treee288dcaa6ce1d875eb413f2c6c8856ea5559de08 /abs/extra/mythexpress
parent2a67b29320c4c371098f519fe36bc8babb59aa29 (diff)
downloadlinhes_pkgbuild-38d2158355d4ebddf3bcf10a488fdf85c4f57d90.zip
linhes_pkgbuild-38d2158355d4ebddf3bcf10a488fdf85c4f57d90.tar.gz
linhes_pkgbuild-38d2158355d4ebddf3bcf10a488fdf85c4f57d90.tar.bz2
mythexpress, remyth: add error page for when the software isn't installed. After install the webpage for each application will redirect the browser to the correct network address.
Diffstat (limited to 'abs/extra/mythexpress')
-rwxr-xr-xabs/extra/mythexpress/PKGBUILD8
-rwxr-xr-xabs/extra/mythexpress/mythexpress.html30
2 files changed, 35 insertions, 3 deletions
diff --git a/abs/extra/mythexpress/PKGBUILD b/abs/extra/mythexpress/PKGBUILD
index 5d8bfba..37a9dfb 100755
--- a/abs/extra/mythexpress/PKGBUILD
+++ b/abs/extra/mythexpress/PKGBUILD
@@ -1,13 +1,13 @@
pkgname=mythexpress
pkgver=20121210
-pkgrel=1
+pkgrel=2
pkgdesc="MythExpress is a browser-based interface to MythTV HTTP streaming capability"
arch=('i686' 'x86_64')
url="https://github.com/MythTV-Clients/MythExpress"
license=('GPL3')
depends=('nodejs' 'avahi' )
makedepends=('git')
-source=( )
+source=('mythexpress.html' )
_gitroot="https://github.com/MythTV-Clients/MythExpress.git"
_gitname=MythExpress
@@ -40,5 +40,7 @@ package() {
cd "${srcdir}"
mkdir -p $pkgdir/usr/$pkgname
rsync -arvp --exclude .git ${_gitname}-build/ $pkgdir/usr/${pkgname}
+ cd $startdir/src
+ install -m755 -D mythexpress.html $pkgdir/data/srv/httpd/htdocs/mythexpress.html
}
-md5sums=()
+md5sums=('93b0d936c5c7838e1c0367f2d5286b3b')
diff --git a/abs/extra/mythexpress/mythexpress.html b/abs/extra/mythexpress/mythexpress.html
new file mode 100755
index 0000000..d9dd9a3
--- /dev/null
+++ b/abs/extra/mythexpress/mythexpress.html
@@ -0,0 +1,30 @@
+<head>
+<script type="text/javascript">
+function r()
+{
+ current_hostname=parent.location.hostname
+ top.frames["content"].location.href = ( "http://" + current_hostname + ":6544" ) ;
+
+}
+
+function express()
+{
+ current_hostname=parent.location.hostname
+ top.frames["content"].location.href = ( "http://" + current_hostname + ":6565" ) ;
+
+ }
+
+function remyth()
+{
+ current_hostname=parent.location.hostname
+ top.frames["content"].location.href = ( "http://" + current_hostname + ":8088" ) ;
+
+ }
+
+
+</script>
+</head>
+<body onload="JavaScript:express();">
+
+</body>
+</html> \ No newline at end of file