summaryrefslogtreecommitdiffstats
path: root/abs/extra/nbd/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-02-17 00:05:58 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-02-19 19:03:05 (GMT)
commit34aea02a41d9c352742211190131dbd72bb1d04c (patch)
tree1fb6feee71190ee9f3686e0aced915f5fa6ee246 /abs/extra/nbd/PKGBUILD
parent088c5b470b114a46fb991d99c2242f04fec0307e (diff)
downloadlinhes_pkgbuild-34aea02a41d9c352742211190131dbd72bb1d04c.zip
linhes_pkgbuild-34aea02a41d9c352742211190131dbd72bb1d04c.tar.gz
linhes_pkgbuild-34aea02a41d9c352742211190131dbd72bb1d04c.tar.bz2
nbd: 3.6
update binary path to /usr/bin refs #961
Diffstat (limited to 'abs/extra/nbd/PKGBUILD')
-rw-r--r--abs/extra/nbd/PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/abs/extra/nbd/PKGBUILD b/abs/extra/nbd/PKGBUILD
index e02e890..cfe0c50 100644
--- a/abs/extra/nbd/PKGBUILD
+++ b/abs/extra/nbd/PKGBUILD
@@ -1,30 +1,26 @@
-# $Id: PKGBUILD 73924 2012-07-17 05:54:37Z svenstaro $
+# $Id: PKGBUILD 103355 2014-01-04 02:43:25Z svenstaro $
# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: Christian Hesse <mail@eworm.de>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Gerhard Brauer <gerbra@archlinux.de>
pkgname=nbd
-pkgver=3.2
-pkgrel=2
+pkgver=3.6
+pkgrel=1
pkgdesc="tools for network block devices, allowing you to use remote block devices over TCP/IP"
arch=('i686' 'x86_64')
url="http://nbd.sourceforge.net"
license=('GPL')
-source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
- config nbd nbd.service)
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.xz
+ config nbd.service)
backup=('etc/nbd-server/config')
depends=('glib2')
install=nbd.install
-md5sums=('9cafce4ecfb55e670d7ded4c8f4e6bc9'
- '2d05d426b8c2708d5f8a0d028fcbae05'
- 'e7b13a8b3369e11927d9917664557efa'
- '5d1acc143018117174f79eff15afa038')
build(){
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --sysconfdir=/etc
+ ./configure --prefix=/usr --sysconfdir=/etc --enable-syslog --sbindir=/usr/bin
make
}
@@ -35,8 +31,10 @@ package() {
make DESTDIR="${pkgdir}" install
install -D -m644 "${srcdir}"/config "${pkgdir}"/etc/nbd-server/config
- install -D -m755 "${srcdir}"/nbd "${pkgdir}"/etc/rc.d/nbd
install -D -m644 "${srcdir}"/nbd.service "${pkgdir}"/usr/lib/systemd/system/nbd.service
install -D -m644 README "${pkgdir}"/usr/share/doc/nbd/README
}
+md5sums=('717213c2c99b693321fe444e319336ba'
+ '2d05d426b8c2708d5f8a0d028fcbae05'
+ '5d1acc143018117174f79eff15afa038')