summaryrefslogtreecommitdiffstats
path: root/abs/extra/openmpi/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-11-24 23:12:04 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-11-24 23:12:04 (GMT)
commit5a39dbc3e9bc8f5acc4d353de37026250415ae74 (patch)
tree04f5ba6ec7f1e3b67882fb19840fba4d557478ca /abs/extra/openmpi/PKGBUILD
parent83095c8c2cac262fd7dd2f2b0bf5b70c40e1982e (diff)
downloadlinhes_pkgbuild-5a39dbc3e9bc8f5acc4d353de37026250415ae74.zip
linhes_pkgbuild-5a39dbc3e9bc8f5acc4d353de37026250415ae74.tar.gz
linhes_pkgbuild-5a39dbc3e9bc8f5acc4d353de37026250415ae74.tar.bz2
openmpi: update to 1.8.3
Diffstat (limited to 'abs/extra/openmpi/PKGBUILD')
-rw-r--r--abs/extra/openmpi/PKGBUILD79
1 files changed, 43 insertions, 36 deletions
diff --git a/abs/extra/openmpi/PKGBUILD b/abs/extra/openmpi/PKGBUILD
index 3e57dde..9c8828c 100644
--- a/abs/extra/openmpi/PKGBUILD
+++ b/abs/extra/openmpi/PKGBUILD
@@ -1,39 +1,43 @@
-# $Id: PKGBUILD 159287 2012-05-20 22:11:21Z stephane $
-# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
+# $Id$
+# Maintainer: Anatol Pomozov <anatol dot pomozov at gmail>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+
pkgname=openmpi
-pkgver=1.6
-pkgrel=2
-pkgdesc="High performance message passing library (MPI)"
-arch=('i686' 'x86_64')
-url="http://www.open-mpi.org"
-license=('custom')
-depends=('gcc-fortran' 'openssh' 'valgrind' 'libltdl' 'hwloc')
-makedepends=('inetutils')
-options=(!libtool)
-source=(http://www.open-mpi.org/software/ompi/v1.6/downloads/${pkgname}-${pkgver}.tar.bz2
- openmpi-hostfile.patch)
-sha1sums=('8b81eea712bb8f8120468003b5f29baecedf2367'
- 'a76da03418a106d57cfd020d0f8d887d7ec9225b')
+pkgver=1.8.3
+pkgrel=1
+pkgdesc='High performance message passing library (MPI)'
+arch=(i686 x86_64)
+url='http://www.open-mpi.org'
+license=(custom)
+depends=(libltdl hwloc)
+makedepends=(inetutils valgrind gcc-fortran)
+optdepends=('gcc-fortran: fortran support')
+options=(staticlibs)
+source=(http://www.open-mpi.org/software/ompi/v1.8/downloads/${pkgname}-${pkgver}.tar.bz2
+ system_ltdl.patch)
+sha1sums=('4be9c5d2a8baee6a80bde94c6485931979a428fe'
+ 'd5f8a3d463f1a1f29ca4725d6fb3b9f8c40799dc')
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ cd $pkgname-$pkgver
- # Make sure we use the system ltdl librariry rather than the ones in the tarball
+ # Make sure we use the system ltdl library rather than the ones in the tarball
rm -r opal/libltdl
+ patch -p1 < ../system_ltdl.patch
+ ./autogen.pl
+}
- # Search for openmpi-default-hostfile in /etc/openmpi
- patch -Np1 -i ../openmpi-hostfile.patch
+build() {
+ cd $pkgname-$pkgver
./configure --prefix=/usr \
--sysconfdir=/etc/${pkgname} \
- --mandir=/usr/share/man \
- --enable-mpi-f90 \
+ --enable-mpi-fortran=all \
--libdir=/usr/lib/${pkgname} \
--with-threads=posix \
--enable-smp-locks \
--with-valgrind \
--enable-memchecker \
- --enable-debug \
--enable-pretty-print-stacktrace \
--without-slurm \
--with-hwloc=/usr \
@@ -44,27 +48,30 @@ build() {
make
}
+check() {
+ cd $pkgname-$pkgver
+
+ make check
+}
+
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
# FS#28583
- install -d -m 755 "${pkgdir}"/usr/lib/pkgconfig
+ install -d -m 755 "$pkgdir"/usr/lib/pkgconfig
for i in ompi-c.pc ompi-cxx.pc ompi-f77.pc ompi-f90.pc ompi.pc; do
- ln -sf /usr/lib/openmpi/pkgconfig/${i} "${pkgdir}"/usr/lib/pkgconfig/
+ ln -sf /usr/lib/openmpi/pkgconfig/$i "$pkgdir"/usr/lib/pkgconfig/
done
# Openmpi's otfinfo conflicts with the one from texlive
- mv "${pkgdir}"/usr/bin/otfinfo{,mpi}
-
- # Openmpi's otfdump conflicts with the one from libotf
- mv "${pkgdir}"/usr/bin/otfdump{,ompi}
+ mv "$pkgdir"/usr/bin/otfinfo{,mpi}
- # Remove dangling symlink
- rm "${pkgdir}"/usr/share/man/man1/orteCC.1
+ # Remove dangling symlink and useless file
+ rm "$pkgdir"/usr/share/vampirtrace/config.log
- install -d -m 755 "${pkgdir}"/etc/ld.so.conf.d
- echo "/usr/lib/${pkgname}" > "${pkgdir}"/etc/ld.so.conf.d/${pkgname}.conf
+ install -d -m 755 "$pkgdir"/etc/ld.so.conf.d
+ echo "/usr/lib/$pkgname" > "$pkgdir"/etc/ld.so.conf.d/$pkgname.conf
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}