summaryrefslogtreecommitdiffstats
path: root/abs/extra/perl-net-smtp-ssl
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-06 17:34:48 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-06 17:34:48 (GMT)
commita88e0a4caaee4269707417416f8e36c754ea6e16 (patch)
treede63f290d0c85422f5c9bb8bfb3e186030f79080 /abs/extra/perl-net-smtp-ssl
parent9b21e2c89af805f7e2e3014075318587ae479396 (diff)
parent28df92c527607da6a77cbc2ba0f8f62bc6dff548 (diff)
downloadlinhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.zip
linhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.tar.gz
linhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/perl-net-smtp-ssl')
-rw-r--r--abs/extra/perl-net-smtp-ssl/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/extra/perl-net-smtp-ssl/PKGBUILD b/abs/extra/perl-net-smtp-ssl/PKGBUILD
new file mode 100644
index 0000000..e4b24bb
--- /dev/null
+++ b/abs/extra/perl-net-smtp-ssl/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 17474 2010-05-24 13:41:50Z cbrannon $
+# Maintainer: Chris Brannon <cmbrannon79@gmail.com>
+# Contributor: Abhishek Dasgupta <abhidg@gmail.com>
+
+pkgname=perl-net-smtp-ssl
+pkgver=1.01
+pkgrel=2
+pkgdesc="SSL support for Net::SMTP"
+arch=(any)
+url="http://search.cpan.org/dist/Net-SMTP-SSL/"
+license=('GPL' 'PerlArtistic')
+depends=('perl-io-socket-ssl')
+source=("http://www.cpan.org/authors/id/C/CW/CWEST/Net-SMTP-SSL-${pkgver}.tar.gz")
+options=(!emptydirs)
+
+build() {
+ cd "${srcdir}/Net-SMTP-SSL-${pkgver}"
+ # Install module into the vendor directories.
+ perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+
+ # Remove .packlist and perllocal.pod files.
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name 'perllocal.pod' -delete
+}
+md5sums=('ba039288ebf7a343feecacd374da8c1a')
+