summaryrefslogtreecommitdiffstats
path: root/abs/extra/perl-sys-mmap/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-06 17:34:48 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-06 17:34:48 (GMT)
commita88e0a4caaee4269707417416f8e36c754ea6e16 (patch)
treede63f290d0c85422f5c9bb8bfb3e186030f79080 /abs/extra/perl-sys-mmap/PKGBUILD
parent9b21e2c89af805f7e2e3014075318587ae479396 (diff)
parent28df92c527607da6a77cbc2ba0f8f62bc6dff548 (diff)
downloadlinhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.zip
linhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.tar.gz
linhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/perl-sys-mmap/PKGBUILD')
-rw-r--r--abs/extra/perl-sys-mmap/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/extra/perl-sys-mmap/PKGBUILD b/abs/extra/perl-sys-mmap/PKGBUILD
new file mode 100644
index 0000000..a5e73f7
--- /dev/null
+++ b/abs/extra/perl-sys-mmap/PKGBUILD
@@ -0,0 +1,27 @@
+# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# Contributor: Ross melin <rdmelin@gmail.com>
+
+# Required by zoneminder =>1.24.0
+
+pkgname=perl-sys-mmap
+pkgver=0.13
+pkgrel=1
+pkgdesc="uses mmap to map in a file as a Perl variable"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~SWALTERS/Sys-Mmap"
+license=('GPL' 'PerlArtistic')
+depends=('perl')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/S/SW/SWALTERS/Sys-Mmap-$pkgver.tar.gz)
+md5sums=('e65a007157e3e26807db52299497109d')
+
+build() {
+ cd $startdir/src/Sys-Mmap-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR=$startdir/pkg || return 1
+ find $startdir/pkg -name '.packlist' -delete
+ find $startdir/pkg -name '*.pod' -delete
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file