summaryrefslogtreecommitdiffstats
path: root/abs/extra/plex-home-theater/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-12-30 20:33:31 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-12-30 20:33:31 (GMT)
commit835bc35ade1cde55470a781b60e4f45032cdef9a (patch)
treeeeddfe7247631c166f33c119ad7daf46d5d70f2a /abs/extra/plex-home-theater/PKGBUILD
parentc9ae566e45dcf7ff871c9c6cb0a5b961ba13be92 (diff)
downloadlinhes_pkgbuild-835bc35ade1cde55470a781b60e4f45032cdef9a.zip
linhes_pkgbuild-835bc35ade1cde55470a781b60e4f45032cdef9a.tar.gz
linhes_pkgbuild-835bc35ade1cde55470a781b60e4f45032cdef9a.tar.bz2
replace plex-home-theater with openpht
update to openpht 1.5.0 plex home theater will not be updated anymore so moving to the community driven fork openpht
Diffstat (limited to 'abs/extra/plex-home-theater/PKGBUILD')
-rwxr-xr-xabs/extra/plex-home-theater/PKGBUILD79
1 files changed, 0 insertions, 79 deletions
diff --git a/abs/extra/plex-home-theater/PKGBUILD b/abs/extra/plex-home-theater/PKGBUILD
deleted file mode 100755
index 6de7cb1..0000000
--- a/abs/extra/plex-home-theater/PKGBUILD
+++ /dev/null
@@ -1,79 +0,0 @@
-# $Id$
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
-# Contributor: Daniel Wallace <daniel.wallace@gatech.edu>
-
-pkgname=plex-home-theater
-pkgver=1.4.1.469
-_pkghash=47a90f01
-pkgrel=2
-pkgdesc='Plex Home Theater'
-arch=('i686' 'x86_64')
-url='http://www.plexapp.com/'
-license=('GPL2')
-install="${pkgname}.install"
-depends=('boost-libs' 'curl' 'ffmpeg-compat' 'glew' 'libcdio' 'libmad'
- 'libmicrohttpd' 'libmpeg2' 'libsamplerate' 'libssh' 'libusb-compat'
- 'libvdpau' 'libxrandr' 'lzo' 'sdl_image' 'sdl_mixer' 'smbclient'
- 'taglib' 'tinyxml' 'yajl')
-makedepends=('boost' 'cmake' 'doxygen' 'git' 'java-environment' 'libcec'
- 'libplist' 'libshairport' 'nasm' 'swig' 'unzip' 'zip')
-optdepends=('libplist: AirPlay support'
- 'libshairport: AirPlay support'
- 'libcec: Pulse-Eight USB-CEC adapter support')
-source=("https://github.com/plexinc/plex-home-theater-public/archive/v${pkgver}-${_pkghash}.tar.gz"
- 'plex-ffmpeg-compat.patch'
- 'plex-libcec.patch'
- 'plex_lib.conf'
- 'plexhometheater.sh')
-
-prepare() {
- cd plex-home-theater-public-${pkgver}-${_pkghash}
-
- patch -Np1 -i ../plex-libcec.patch
- patch -Np1 -i ../plex-ffmpeg-compat.patch
-}
-
-build() {
- cd plex-home-theater-public-${pkgver}-${_pkghash}
-
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build && cd build
-
- cmake .. \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_C_FLAGS="$CMAKE_C_FLAGS -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include" \
- -DCMAKE_CXX_FLAGS="$CMAKE_CXX_FLAGS -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include" \
- -DCREATE_BUNDLE='FALSE' \
- -DDUMP_SYMBOLS='FALSE' \
- -DENABLE_AUTOUPDATE='FALSE' \
- -DENABLE_PYTHON='TRUE' \
- -DPYTHON_EXEC='/usr/bin/python2' \
- -DUSE_INTERNAL_FFMPEG='FALSE'
- make
-}
-
-package() {
- cd plex-home-theater-public-${pkgver}-${_pkghash}/build
-
- make DESTDIR="${pkgdir}" install
- install -dm 755 "${pkgdir}"/usr/{lib/plexhometheater,share/{applications,pixmaps}}
- mv "${pkgdir}"/usr/bin/{system,xbmc-xrandr} "${pkgdir}"/usr/lib/plexhometheater/
- mv "${pkgdir}"/usr/share/XBMC "${pkgdir}"/usr/share/plexhometheater
- rm -rf "${pkgdir}"/usr/bin/*.so
- install -Dm 755 "${srcdir}"/plexhometheater.sh "${pkgdir}"/usr/LH/bin/plexhometheater.sh
- install -m 644 ../plex/Resources/plexhometheater.desktop "${pkgdir}"/usr/share/applications/
- install -m 644 ../plex/Resources/plex-icon-256.png "${pkgdir}"/usr/share/pixmaps/plexhometheater.png
-
- # LinHES stuff
- #add in plex_lib.conf
- install -D -m0744 ${srcdir}/plex_lib.conf ${pkgdir}/etc/gen_lib_xml.d/plex_lib.conf
-}
-
-# vim: ts=2 sw=2 et:
-md5sums=('62456ec6266f769f2c873ed7132b26d3'
- '6704244166497db7fa6b3ddd43a0e53b'
- '0f753e1ebea13e5a2029a59b9db79877'
- 'c1eedd9f89ee727230833db9ef1e5d29'
- '4ceae60ed2f9e4304eda4f80d407e799')