summaryrefslogtreecommitdiffstats
path: root/abs/extra/premake/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-09-03 19:31:19 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-09-03 19:31:19 (GMT)
commit54a82868b7fa5ff72c13ea704fe3c009889384ff (patch)
tree0214573f802399f7982d3a75a661f02ed0bffa54 /abs/extra/premake/PKGBUILD
parent39576222150a6983f7ba63ba2583c8a5e7374aab (diff)
downloadlinhes_pkgbuild-54a82868b7fa5ff72c13ea704fe3c009889384ff.zip
linhes_pkgbuild-54a82868b7fa5ff72c13ea704fe3c009889384ff.tar.gz
linhes_pkgbuild-54a82868b7fa5ff72c13ea704fe3c009889384ff.tar.bz2
Merge remote-tracking branch 'origin/testing' into testing
# By Britney Fransen (10) and others # Via Britney Fransen * origin/testing: mythdb-initial: add MiscStatusScript value to initial db. refs #845. LinHES-system: remove dup .install keylaunch: update .keylaunchrc to run mythtv-setup as user rsyslog: increase log retention to 2 weeks runit-scripts: enable cron logging to syslog premake:initial inclusion. closes #801 libaacs-git:initial inclusion. closes #801 aacskeys:initial inclusion. closes #801 LinHES-system: Add scripts for misc status in MythWeb. closes #845. linhes-scripts: tweak myth2mkv. Update version to 0.25-004 dvb-firmware: add xc5000c firmware. change xc5000 modprobe options. closes #844 v4l-dvb: update to snapshot from 20120828. refs #844 LinHES-system: update myth_status.py to work with tuners in error. closes #843 curlftpfs: Initial Inclusion. linhes-scripts: minor changes to myth2mkv mythtv:Bumped to latest fixes. Added ./configure items to close #842. LinHES-config:7.4 rdt 9th anniversary release. Conflicts: abs/core/LinHES-config/LinHES-release abs/core/LinHES-config/PKGBUILD abs/core/LinHES-system/PKGBUILD abs/core/keylaunch/PKGBUILD abs/core/linhes-scripts/PKGBUILD abs/core/mythdb-initial/PKGBUILD abs/core/mythdb-initial/mc.sql abs/core/mythtv/stable-0.25/mythtv/PKGBUILD abs/core/runit-scripts/PKGBUILD
Diffstat (limited to 'abs/extra/premake/PKGBUILD')
-rw-r--r--abs/extra/premake/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/extra/premake/PKGBUILD b/abs/extra/premake/PKGBUILD
new file mode 100644
index 0000000..f4343e1
--- /dev/null
+++ b/abs/extra/premake/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Anders Bergh <anders1@gmail.com>
+# Contributor: Mildred <silkensedai@online.fr>
+# Maintainer: Daniel J Griffiths <griffithsdj@archlinux.us>
+
+pkgname=premake
+pkgver=3.7
+pkgrel=1
+pkgdesc="A build configuration tool. Describe your build using Lua and generate \
+the project files for your specific toolset."
+arch=('i686' 'x86_64')
+url="http://premake.sourceforge.net"
+license=('GPL')
+makedepends=()
+source=("http://downloads.sourceforge.net/sourceforge/premake/premake-src-${pkgver}.zip")
+md5sums=('8d30dc5bbc52aad81abb1509c1dd7d8f')
+
+build() {
+ cd ${srcdir}/Premake-${pkgver}
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}/Premake-${pkgver}
+ install -Dm755 bin/premake ${pkgdir}/usr/bin/premake
+}