summaryrefslogtreecommitdiffstats
path: root/abs/extra/python-imaging/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-06 17:34:48 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-06 17:34:48 (GMT)
commita88e0a4caaee4269707417416f8e36c754ea6e16 (patch)
treede63f290d0c85422f5c9bb8bfb3e186030f79080 /abs/extra/python-imaging/PKGBUILD
parent9b21e2c89af805f7e2e3014075318587ae479396 (diff)
parent28df92c527607da6a77cbc2ba0f8f62bc6dff548 (diff)
downloadlinhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.zip
linhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.tar.gz
linhes_pkgbuild-a88e0a4caaee4269707417416f8e36c754ea6e16.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/python-imaging/PKGBUILD')
-rw-r--r--abs/extra/python-imaging/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/abs/extra/python-imaging/PKGBUILD b/abs/extra/python-imaging/PKGBUILD
new file mode 100644
index 0000000..e469a94
--- /dev/null
+++ b/abs/extra/python-imaging/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id: PKGBUILD 87626 2010-08-17 13:21:07Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Contributor: simo <simo@archlinux.org>
+
+pkgname=python-imaging
+pkgver=1.1.7
+pkgrel=2
+pkgdesc="PIL. Provides image processing capabilities for python"
+arch=('i686' 'x86_64')
+url="http://www.pythonware.com/products/pil/index.htm"
+license=('custom:"pil"')
+depends=('python2' 'libjpeg' 'freetype2')
+makedepends=('tk')
+optdepends=('tk')
+provides=("pil=$pkgver")
+conflicts=('pil')
+replaces=('pil')
+source=(http://effbot.org/downloads/Imaging-$pkgver.tar.gz)
+md5sums=('fc14a54e1ce02a0225be8854bfba478e')
+
+build() {
+ cd $srcdir/Imaging-$pkgver
+ python2 setup.py build_ext
+}
+
+package() {
+ cd $srcdir/Imaging-$pkgver
+ python2 setup.py install --root=$pkgdir
+ install -dm755 $pkgdir/usr/include/python2.7/
+ install -m644 -t $pkgdir/usr/include/python2.7/ libImaging/*.h
+
+ # do not have files ending in .py in /usr/bin
+ for f in pildriver pilprint pilconvert pilfile pilfont; do
+ mv $pkgdir/usr/bin/$f{.py,}
+ done
+
+ # Install license
+ install -Dm644 $srcdir/Imaging-$pkgver/README \
+ $pkgdir/usr/share/licenses/$pkgname/README
+}