summaryrefslogtreecommitdiffstats
path: root/abs/extra/python-pyserial/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
commitb172f79fadb565ecfbcec9508f9377d8618a4f4c (patch)
treebf8823b07e3313c3afa000a9b31e4f9a735cb818 /abs/extra/python-pyserial/PKGBUILD
parentf9d54ab7c3853208484e304bc6cf40ab0f79d400 (diff)
parent5e7027c6194237ca1dc5fcbb3648483a970fb500 (diff)
downloadlinhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.zip
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.gz
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra/python-pyserial/PKGBUILD')
-rw-r--r--abs/extra/python-pyserial/PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/abs/extra/python-pyserial/PKGBUILD b/abs/extra/python-pyserial/PKGBUILD
new file mode 100644
index 0000000..d90ee2d
--- /dev/null
+++ b/abs/extra/python-pyserial/PKGBUILD
@@ -0,0 +1,20 @@
+# $Id: PKGBUILD 82 2009-07-17 19:56:55Z aaron $
+# Maintainer: Douglas Soares de Andrade <dsandrade@gmail.com>
+# Contributor: Douglas Soares de Andrade <dsandrade@gmail.com>
+
+pkgname=python-pyserial
+pkgver=2.4
+pkgrel=1
+pkgdesc="Multiplatform Serial Port Module for Python"
+arch=('i686' 'x86_64')
+url="http://pyserial.sf.net"
+license=('custom:PYTHON')
+depends=('python')
+source=(http://downloads.sourceforge.net/sourceforge/pyserial/pyserial-$pkgver.tar.gz)
+
+build() {
+ cd $startdir/src/pyserial-$pkgver
+ python setup.py install --root=$startdir/pkg
+ install -D -m644 LICENSE.txt $startdir/pkg/usr/share/licenses/$pkgname/LICENSE.txt
+}
+md5sums=('eec19df59fd75ba5a136992897f8e468')