summaryrefslogtreecommitdiffstats
path: root/abs/extra/ragel
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-02-15 21:30:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-02-15 21:30:12 (GMT)
commit6253390f343d6a40f301ecf83190dd1e89f91b7b (patch)
treecc13f61e612ffd3fb36b70c6dc07484eacc11333 /abs/extra/ragel
parent80b7b83c7deb5acfe101fc5d6d9f6563b55a3e09 (diff)
downloadlinhes_pkgbuild-6253390f343d6a40f301ecf83190dd1e89f91b7b.zip
linhes_pkgbuild-6253390f343d6a40f301ecf83190dd1e89f91b7b.tar.gz
linhes_pkgbuild-6253390f343d6a40f301ecf83190dd1e89f91b7b.tar.bz2
ragel: initial inclusion. dep of harfbuzz
Diffstat (limited to 'abs/extra/ragel')
-rw-r--r--abs/extra/ragel/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/extra/ragel/PKGBUILD b/abs/extra/ragel/PKGBUILD
new file mode 100644
index 0000000..7d45026
--- /dev/null
+++ b/abs/extra/ragel/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: Michael P <ptchinster@archlinux.us>
+# Contributor: Roberto Alsina <ralsina@kde.org>
+# Contributor: Will Chappell <mr.chapendi@gmail.com>
+# Contributor: Jesse Young <jesse.young@gmail.com>
+# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=ragel
+pkgver=6.10
+pkgrel=2
+pkgdesc="Compiles finite state machines from regular languages into executable C, C++, Objective-C, or D code."
+arch=('x86_64')
+url="http://www.complang.org/ragel/"
+license=('GPL')
+depends=('gcc-libs')
+source=(https://www.colm.net/files/$pkgname/$pkgname-$pkgver.tar.gz{,.asc})
+validpgpkeys=(C3260F001EE3780F1BC3D4F650FE47277DC196FB)
+md5sums=('748cae8b50cffe9efcaa5acebc6abf0d'
+ 'SKIP')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr CXXFLAGS="$CXXFLAGS -std=gnu++98"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+ install -m0644 -D ragel.vim "$pkgdir"/usr/share/vim/vimfiles/syntax/ragel.vim
+}