summaryrefslogtreecommitdiffstats
path: root/abs/extra/recstat/recstat.py
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
commitb172f79fadb565ecfbcec9508f9377d8618a4f4c (patch)
treebf8823b07e3313c3afa000a9b31e4f9a735cb818 /abs/extra/recstat/recstat.py
parentf9d54ab7c3853208484e304bc6cf40ab0f79d400 (diff)
parent5e7027c6194237ca1dc5fcbb3648483a970fb500 (diff)
downloadlinhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.zip
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.gz
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra/recstat/recstat.py')
-rw-r--r--abs/extra/recstat/recstat.py38
1 files changed, 38 insertions, 0 deletions
diff --git a/abs/extra/recstat/recstat.py b/abs/extra/recstat/recstat.py
new file mode 100644
index 0000000..8def041
--- /dev/null
+++ b/abs/extra/recstat/recstat.py
@@ -0,0 +1,38 @@
+#!/usr/bin/python
+
+import httplib
+import serial,time
+
+mythStatus = "127.0.0.1:6544"
+encoder1 = "Encoder 1 "
+encoder2 = "Encoder 2 "
+recording = "is local on mythtv and is recording"
+watching = "is local on mythtv and is watching"
+
+#Open COM2
+s = serial.Serial(1)
+#Turn off all lights
+s.setDTR(0)
+s.setRTS(0)
+
+while(True):
+ conn = httplib.HTTPConnection(mythStatus)
+ conn.request("GET", "/")
+ r1 = conn.getresponse()
+ results = r1.read()
+
+ if(results.find(encoder1+recording)!=-1):
+ s.setDTR(1)
+ elif (results.find(encoder1+watching) !=-1):
+ s.setDTR(1)
+ else:
+ s.setDTR(0)
+
+ if(results.find(encoder2+recording)!=-1):
+ s.setRTS(1)
+ elif (results.find(encoder2+watching) !=-1):
+ s.setRTS(1)
+ else:
+ s.setRTS(0)
+
+ time.sleep(1)