summaryrefslogtreecommitdiffstats
path: root/abs/extra/remyth
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-05 16:12:32 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-05 16:12:32 (GMT)
commit0e0f774e3b78d143dd1e932ee49bef80d0a6e970 (patch)
tree86e95c670dac103c350e74d626740a7e29f49b31 /abs/extra/remyth
parent0ab5cd4e6e8b1ee1f04b50b6079c6c29d5143980 (diff)
downloadlinhes_pkgbuild-0e0f774e3b78d143dd1e932ee49bef80d0a6e970.zip
linhes_pkgbuild-0e0f774e3b78d143dd1e932ee49bef80d0a6e970.tar.gz
linhes_pkgbuild-0e0f774e3b78d143dd1e932ee49bef80d0a6e970.tar.bz2
remyth: adding it
refs #863 closes #863
Diffstat (limited to 'abs/extra/remyth')
-rwxr-xr-xabs/extra/remyth/PKGBUILD45
-rw-r--r--abs/extra/remyth/service_type.js.patch24
2 files changed, 69 insertions, 0 deletions
diff --git a/abs/extra/remyth/PKGBUILD b/abs/extra/remyth/PKGBUILD
new file mode 100755
index 0000000..5208ace
--- /dev/null
+++ b/abs/extra/remyth/PKGBUILD
@@ -0,0 +1,45 @@
+pkgname=remyth
+pkgver=20121031
+pkgrel=1
+pkgdesc="This project is meant to provide a nicer remote for your MythTV Frontends. "
+arch=('i686' 'x86_64')
+url="https://github.com/SchraderMJ11/ReMyth"
+license=('GPL')
+depends=('nodejs' 'avahi' )
+makedepends=('git')
+source=(service_type.js.patch )
+
+_gitroot="https://github.com/SchraderMJ11/ReMyth.git"
+_gitname=ReMyth
+
+build() {
+ cd "${srcdir}"
+
+ if [ ! -d "${srcdir}/${_gitname}" ]; then
+ git clone ${_gitroot}
+ else
+ cd ${_gitname} && git pull origin
+ fi
+
+ msg "GIT checkout done."
+
+
+ cd "${srcdir}"
+ if [ -e ${_gitname}-build ]
+ then
+ rm -rf ${_gitname}-build
+ fi
+ cp -rf "${_gitname}" "${_gitname}-build"
+
+ cd "${srcdir}/${_gitname}-build"
+ npm install || exit 1
+ patch -Np0 -i ${srcdir}/service_type.js.patch || return 1
+
+}
+
+package() {
+ cd "${srcdir}"
+ mkdir -p $pkgdir/usr/$pkgname
+ rsync -arvp --exclude .git ${_gitname}-build/ $pkgdir/usr/${pkgname}
+}
+md5sums=('69f9edd22284e003249902999579d7c2')
diff --git a/abs/extra/remyth/service_type.js.patch b/abs/extra/remyth/service_type.js.patch
new file mode 100644
index 0000000..ef1feca
--- /dev/null
+++ b/abs/extra/remyth/service_type.js.patch
@@ -0,0 +1,24 @@
+--- node_modules/mdns/lib/service_type.js.orig 2012-11-05 02:42:27.910994908 +0000
++++ node_modules/mdns/lib/service_type.js 2012-11-05 02:43:26.784326471 +0000
+@@ -156,8 +156,8 @@
+ if (str.length === 0) {
+ throw new Error('type ' + str + ' must not be empty');
+ }
+- if (str.length > 14) {
+- throw new Error('type ' + str + ' has more than 14 characters');
++ if (str.length > 24) {
++ throw new Error('type ' + str + ' has more than 24 characters');
+ }
+ if (str.match(charset_regex)) {
+ throw new Error('type ' + str + ' may only contain alphanumeric ' +
+@@ -170,8 +170,8 @@
+ if (str.length === 0) {
+ throw new Error('type string must not be empty');
+ }
+- if (str.length > 15) {
+- throw new Error('type ' + _uu(str) + ' has more than 14 characters');
++ if (str.length > 25) {
++ throw new Error('type ' + _uu(str) + ' has more than 24 characters');
+ }
+ if ( ! str.match(format_regex)) {
+ throw new Error('type ' + str + ' must start with an underscore ' +