summaryrefslogtreecommitdiffstats
path: root/abs/extra/remyth
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-01-15 18:02:19 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-01-15 18:02:19 (GMT)
commit38d2158355d4ebddf3bcf10a488fdf85c4f57d90 (patch)
treee288dcaa6ce1d875eb413f2c6c8856ea5559de08 /abs/extra/remyth
parent2a67b29320c4c371098f519fe36bc8babb59aa29 (diff)
downloadlinhes_pkgbuild-38d2158355d4ebddf3bcf10a488fdf85c4f57d90.zip
linhes_pkgbuild-38d2158355d4ebddf3bcf10a488fdf85c4f57d90.tar.gz
linhes_pkgbuild-38d2158355d4ebddf3bcf10a488fdf85c4f57d90.tar.bz2
mythexpress, remyth: add error page for when the software isn't installed. After install the webpage for each application will redirect the browser to the correct network address.
Diffstat (limited to 'abs/extra/remyth')
-rwxr-xr-xabs/extra/remyth/PKGBUILD9
-rwxr-xr-xabs/extra/remyth/remyth.html30
2 files changed, 36 insertions, 3 deletions
diff --git a/abs/extra/remyth/PKGBUILD b/abs/extra/remyth/PKGBUILD
index 47d97cc..7243a12 100755
--- a/abs/extra/remyth/PKGBUILD
+++ b/abs/extra/remyth/PKGBUILD
@@ -1,13 +1,13 @@
pkgname=remyth
pkgver=20121210
-pkgrel=1
+pkgrel=3
pkgdesc="This project is meant to provide a nicer remote for your MythTV Frontends. "
arch=('i686' 'x86_64')
url="https://github.com/SchraderMJ11/ReMyth"
license=('GPL')
depends=('nodejs' 'avahi' )
makedepends=('git')
-source=(service_type.js.patch )
+source=(service_type.js.patch remyth.html)
_gitroot="https://github.com/SchraderMJ11/ReMyth.git"
_gitname=ReMyth
@@ -41,5 +41,8 @@ package() {
cd "${srcdir}"
mkdir -p $pkgdir/usr/$pkgname
rsync -arvp --exclude .git ${_gitname}-build/ $pkgdir/usr/${pkgname}
+ cd $startdir/src
+ install -m755 -D remyth.html $pkgdir/data/srv/httpd/htdocs/remyth.html
}
-md5sums=('69f9edd22284e003249902999579d7c2')
+md5sums=('69f9edd22284e003249902999579d7c2'
+ 'bce9d81d3aa3c39f8a4fefe3bfdb77f4')
diff --git a/abs/extra/remyth/remyth.html b/abs/extra/remyth/remyth.html
new file mode 100755
index 0000000..4d1ddb3
--- /dev/null
+++ b/abs/extra/remyth/remyth.html
@@ -0,0 +1,30 @@
+<head>
+<script type="text/javascript">
+function r()
+{
+ current_hostname=parent.location.hostname
+ top.frames["content"].location.href = ( "http://" + current_hostname + ":6544" ) ;
+
+}
+
+function express()
+{
+ current_hostname=parent.location.hostname
+ top.frames["content"].location.href = ( "http://" + current_hostname + ":6565" ) ;
+
+ }
+
+function remyth()
+{
+ current_hostname=parent.location.hostname
+ top.frames["content"].location.href = ( "http://" + current_hostname + ":8088" ) ;
+
+ }
+
+
+</script>
+</head>
+<body onload="JavaScript:remyth();">
+
+</body>
+</html> \ No newline at end of file