summaryrefslogtreecommitdiffstats
path: root/abs/extra/scons
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-12-02 18:13:59 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-12-02 18:13:59 (GMT)
commit066bcb38c4b416f0c380e9c8292a50f9103b72b6 (patch)
tree07de64551a26f8a292dd1fff09f006334d7e1396 /abs/extra/scons
parentb0043b3d2e43f154d7a4d48db95ef59f2d504fdd (diff)
parentb5cb0290860bd55f2fd25238996601f2fd749615 (diff)
downloadlinhes_pkgbuild-066bcb38c4b416f0c380e9c8292a50f9103b72b6.zip
linhes_pkgbuild-066bcb38c4b416f0c380e9c8292a50f9103b72b6.tar.gz
linhes_pkgbuild-066bcb38c4b416f0c380e9c8292a50f9103b72b6.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/scons')
-rw-r--r--abs/extra/scons/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/extra/scons/PKGBUILD b/abs/extra/scons/PKGBUILD
new file mode 100644
index 0000000..edc4fbc
--- /dev/null
+++ b/abs/extra/scons/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 90304 2010-09-10 14:41:36Z schiv $
+# Maintainer: Ray Rashif <schiv@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+# Contributor: Lukas Sabota <punkrockguy318@comcast.net>
+# Contributor: Brice Carpentier <brice@dlfp.org>
+
+pkgname=scons
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Extensible Python-based build utility"
+arch=('any')
+url="http://scons.org"
+license=('MIT')
+depends=('python2')
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('beca648b894cdbf85383fffc79516d18')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ python2 setup.py install --standard-lib \
+ --prefix=/usr \
+ --install-data=/usr/share \
+ --optimize=1 \
+ --root="$pkgdir"
+
+ # fix for python 2.7
+ sed -i 's:^#!.*bin/env python:#!/usr/bin/env python2:' "$pkgdir"/usr/bin/*
+
+ install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
+