summaryrefslogtreecommitdiffstats
path: root/abs/extra/shellinabox/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-08-14 16:33:01 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-08-14 16:33:01 (GMT)
commitcecb9fe3e3777a82a005a196011b516609641b44 (patch)
tree1901c92cd7583ebae3a0b1fa715a752b48712640 /abs/extra/shellinabox/PKGBUILD
parentc3cf667476326127e9f71bd7ec7fb4af5eb7def8 (diff)
downloadlinhes_pkgbuild-cecb9fe3e3777a82a005a196011b516609641b44.zip
linhes_pkgbuild-cecb9fe3e3777a82a005a196011b516609641b44.tar.gz
linhes_pkgbuild-cecb9fe3e3777a82a005a196011b516609641b44.tar.bz2
shellinabox: add lighttpd conf
Diffstat (limited to 'abs/extra/shellinabox/PKGBUILD')
-rw-r--r--abs/extra/shellinabox/PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/abs/extra/shellinabox/PKGBUILD b/abs/extra/shellinabox/PKGBUILD
index 6032aff..680de85 100644
--- a/abs/extra/shellinabox/PKGBUILD
+++ b/abs/extra/shellinabox/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Brian Moore <archlinux@cptl.org>
pkgname=shellinabox
pkgver=2.14
-pkgrel=3
+pkgrel=4
pkgdesc="A web-based ssh client."
arch=('i686' 'x86_64')
url="http://shellinabox.com/"
@@ -11,11 +11,8 @@ optdepends=('openssh: SSL support')
makedepends=(openssh)
install=shellinaboxd.install
backup=('etc/conf.d/shellinaboxd')
-source=("http://shellinabox.googlecode.com/files/$pkgname-$pkgver.tar.gz" "shellinaboxd.rc.d" "shellinaboxd.conf.d" "shellinaboxd.service")
-md5sums=('6c63b52edcebc56ee73a108e7211d174'
- 'feea22575089cc7eb4925b1daff88b8c'
- '77e487f36da2abe51251500f4a1e024f'
- 'be649866d06ba497d88bb14f3e58f862')
+source=("http://shellinabox.googlecode.com/files/$pkgname-$pkgver.tar.gz" "shellinaboxd.rc.d" "shellinaboxd.conf.d" "shellinaboxd.service"
+ "shellinaboxd.include" "shellinaboxd.gen_light_conf.d")
prepare() {
cd "$srcdir/$pkgname-$pkgver"
@@ -37,4 +34,16 @@ package() {
install -D -m644 $srcdir/shellinaboxd.service $pkgdir/usr/lib/systemd/system/shellinaboxd.service
install -Dm644 $srcdir/shellinaboxd.conf.d $pkgdir/etc/conf.d/shellinaboxd
install -dm700 -o nobody $pkgdir/var/lib/shellinabox
+
+ #install conf files for lighttpd
+ mkdir -p ${pkgdir}/etc/lighttpd
+ install -D -m 644 ${srcdir}/shellinaboxd.include ${pkgdir}/etc/lighttpd/
+ #gen_light_conf
+ install -D -m 744 ${srcdir}/shellinaboxd.gen_light_conf.d ${pkgdir}/etc/gen_light_conf.d/shellinaboxd.conf
}
+md5sums=('6c63b52edcebc56ee73a108e7211d174'
+ 'feea22575089cc7eb4925b1daff88b8c'
+ '77e487f36da2abe51251500f4a1e024f'
+ 'be649866d06ba497d88bb14f3e58f862'
+ '06b131e47522d8028aa245c1b8884e00'
+ 'aadd1edf4110aca2d16d806791e90019')