summaryrefslogtreecommitdiffstats
path: root/abs/extra/snappy
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-01-23 19:03:23 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-01-23 19:03:23 (GMT)
commit6c79776d89c3708886adfb9a78ba58f1ae6be3bd (patch)
treef658350da7f909984a4dc88249394ac9da7aeee0 /abs/extra/snappy
parent9e5f101fba179afe5c45bd0f782a56ea32c71d15 (diff)
downloadlinhes_pkgbuild-6c79776d89c3708886adfb9a78ba58f1ae6be3bd.zip
linhes_pkgbuild-6c79776d89c3708886adfb9a78ba58f1ae6be3bd.tar.gz
linhes_pkgbuild-6c79776d89c3708886adfb9a78ba58f1ae6be3bd.tar.bz2
snappy: initial inclusion. dep of google-chrome
Diffstat (limited to 'abs/extra/snappy')
-rw-r--r--abs/extra/snappy/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/abs/extra/snappy/PKGBUILD b/abs/extra/snappy/PKGBUILD
new file mode 100644
index 0000000..3912d35
--- /dev/null
+++ b/abs/extra/snappy/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer: Dave Reisner <dreisner@archlinux.org>
+# Contributor: Antony Male <antony dot male at geemail dot com>>
+
+pkgname=snappy
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='A fast compressor/decompressor library'
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/snappy/"
+license=('BSD')
+depends=('glibc' 'gcc-libs')
+checkdepends=('zlib')
+source=("http://snappy.googlecode.com/files/$pkgname-$pkgver.tar.gz")
+md5sums=('8887e3b7253b22a31f5486bca3cbc1c2')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ # compile without assertions
+ CXXFLAGS+=\ -DNDEBUG
+
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ # compile without assertions
+ CXXFLAGS+=\ -DNDEBUG
+
+ make -C "$pkgname-$pkgver" check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+ install -m644 -D COPYING "$pkgdir/usr/share/licenses/snappy/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: