summaryrefslogtreecommitdiffstats
path: root/abs/extra/strace/PKGBUILD
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-08-06 19:10:30 (GMT)
committerCecil <knoppmyth@gmail.com>2011-08-06 19:10:30 (GMT)
commitad58e3033f6bb5137b8dcb0e7eca12d50d888402 (patch)
tree9321335a68173bc3e4c1d237c19c8880411fa676 /abs/extra/strace/PKGBUILD
parent998faf16b1b62493b39aa13b3cb53dfac266ef4c (diff)
parent9709ca528ca5dfbdb6ec6ea283ac6670e8f33b9d (diff)
downloadlinhes_pkgbuild-ad58e3033f6bb5137b8dcb0e7eca12d50d888402.zip
linhes_pkgbuild-ad58e3033f6bb5137b8dcb0e7eca12d50d888402.tar.gz
linhes_pkgbuild-ad58e3033f6bb5137b8dcb0e7eca12d50d888402.tar.bz2
Merge branch 'testing' of ssh://cesman@linhes.org/mount/repository/linhes_pkgbuild into testing
Conflicts: abs/core/tzdata/PKGBUILD
Diffstat (limited to 'abs/extra/strace/PKGBUILD')
-rw-r--r--abs/extra/strace/PKGBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/abs/extra/strace/PKGBUILD b/abs/extra/strace/PKGBUILD
index c965f24..5a33af7 100644
--- a/abs/extra/strace/PKGBUILD
+++ b/abs/extra/strace/PKGBUILD
@@ -1,21 +1,27 @@
-# $Id: PKGBUILD 13699 2008-09-27 22:25:37Z giovanni $
+# $Id$
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
pkgname=strace
-pkgver=4.5.18
+pkgver=4.6
pkgrel=1
pkgdesc="A useful diagnositic, instructional, and debugging tool"
arch=('i686' 'x86_64')
-license=('custom')
url="http://sourceforge.net/projects/strace/"
-depends=('glibc')
-source=(http://downloads.sourceforge.net/sourceforge/strace/strace-$pkgver.tar.bz2)
-md5sums=('e9449fcee97e6a8ed73934c883c870e0')
+license=('custom')
+depends=('perl')
+source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-$pkgver.tar.xz)
+md5sums=('e537b2b1afeec70c0e6e27a0d0fd671e')
build() {
- cd $startdir/src/$pkgname-$pkgver
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr
- make || return 1
- make DESTDIR=$startdir/pkg install
- install -Dm644 COPYRIGHT ${startdir}/pkg/usr/share/licenses/strace/COPYRIGHT
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+
+ install -Dm644 COPYRIGHT ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}