summaryrefslogtreecommitdiffstats
path: root/abs/extra/strace/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2011-08-06 01:13:55 (GMT)
committerJames Meyer <james.meyer@operamail.com>2011-08-06 01:13:55 (GMT)
commit12d025b342ea99681a2b9d830a153ced182daca1 (patch)
treed9943ed95e570c0706c6b5021b4570894877325a /abs/extra/strace/PKGBUILD
parentbcfb3dc1bd231f91914f917149164d41a2f3ce0a (diff)
parent9cc464bde03a97d6cbea14420b1b2ee32ca3ca00 (diff)
downloadlinhes_pkgbuild-12d025b342ea99681a2b9d830a153ced182daca1.zip
linhes_pkgbuild-12d025b342ea99681a2b9d830a153ced182daca1.tar.gz
linhes_pkgbuild-12d025b342ea99681a2b9d830a153ced182daca1.tar.bz2
Merge branch 'testing' of ssh://jams@linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/strace/PKGBUILD')
-rw-r--r--abs/extra/strace/PKGBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/abs/extra/strace/PKGBUILD b/abs/extra/strace/PKGBUILD
index c965f24..5a33af7 100644
--- a/abs/extra/strace/PKGBUILD
+++ b/abs/extra/strace/PKGBUILD
@@ -1,21 +1,27 @@
-# $Id: PKGBUILD 13699 2008-09-27 22:25:37Z giovanni $
+# $Id$
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
pkgname=strace
-pkgver=4.5.18
+pkgver=4.6
pkgrel=1
pkgdesc="A useful diagnositic, instructional, and debugging tool"
arch=('i686' 'x86_64')
-license=('custom')
url="http://sourceforge.net/projects/strace/"
-depends=('glibc')
-source=(http://downloads.sourceforge.net/sourceforge/strace/strace-$pkgver.tar.bz2)
-md5sums=('e9449fcee97e6a8ed73934c883c870e0')
+license=('custom')
+depends=('perl')
+source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-$pkgver.tar.xz)
+md5sums=('e537b2b1afeec70c0e6e27a0d0fd671e')
build() {
- cd $startdir/src/$pkgname-$pkgver
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr
- make || return 1
- make DESTDIR=$startdir/pkg install
- install -Dm644 COPYRIGHT ${startdir}/pkg/usr/share/licenses/strace/COPYRIGHT
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+
+ install -Dm644 COPYRIGHT ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}